Subject: [PATCH v1] Fix typos in pg_bsd_indent: "dont" -> "don't" in comments Anexo: o arquivo

From: Thiago Caserta <[email-masked]>
Date: Tue, 24 Mar 2026 19:59:51 +0000

Hi hackers,

Attached is a patch that fixes ten instances of missing apostrophe in contractions ("dont" -> "don't") in pg_bsd_indent source code comments.

I'm aware pg_bsd_indent is derived from FreeBSD's indent tool.
These are minor comment-only changes that don't affect behavior.

 If preferred, I can submit these upstream to FreeBSD as well.

Affected files:
  - src/tools/pg_bsd_indent/indent.c (7 instances)
  - src/tools/pg_bsd_indent/io.c (1 instance)
  - src/tools/pg_bsd_indent/pr_comment.c (2 instances)

 The patch applies cleanly against current HEAD (dd5716f3c74).

 Best regards,
 Thiago Caserta <https://aka.ms/GetOutlookForMac>

---

From: Michael Paquier <[email-masked]>
Date: Fri, 27 Mar 2026 07:54:02 +0900

On Tue, Mar 24, 2026 at 07:59:51PM +0000, Thiago Caserta wrote:
> Attached is a patch that fixes ten instances of missing apostrophe
>  in contractions ("dont" -> "don't") in pg_bsd_indent source code
>  comments.

Grabbed this set as well.
--
Michael

---

From: Andres Freund <[email-masked]>
Date: Thu, 26 Mar 2026 20:15:37 -0400

Hi,

On 2026-03-27 00:21:22 +0100, Álvaro Herrera wrote:
> On 2026-Mar-27, Michael Paquier wrote:
> 

FWIW, I think this a pointless kind of change. Nobody is going to be confused
by the current spelling.

> I think waiting for it to be taken by FreeBSD wouldn't be a bad thing.

We haven't integrated changes from FreeBSD in decades, I think? I doubt it'll
ever happen again, we've patched it too much for that, I suspect.

Greetings,

Andres

---

From: Bruce Momjian <[email-masked]>
Date: Thu, 26 Mar 2026 20:17:51 -0400

> ever happen again, we've patched it too much for that, I suspect.

Yes, I think that is true.

-- 
  Bruce Momjian  <[email-masked]>        https://momjian.us
  EDB                                      https://enterprisedb.com

  Do not let urgent matters crowd out time for investment in the future.

---

From: Michael Paquier <[email-masked]>
Date: Fri, 27 Mar 2026 12:19:37 +0900

> Yes, I think that is true.

Updates are unlikely, IMO, but who knows.  FWIW, I don't mind fixing
these.  At least somebody has spent some time sending a patch for
them.
--
Michael

---

From: Bruce Momjian <[email-masked]>
Date: Thu, 26 Mar 2026 23:20:14 -0400

> these.  At least somebody has spent some time sending a patch for

Agreed.