Subject: DOCS: typo on CLUSTER page

From: Peter Smith <[email-masked]>
Date: Wed, 18 Mar 2026 12:43:06 +1100

Hi.

Is this a tiny typo on the CLUSTER docs page?

PSA patch.

======
Kind Regards,
Peter Smith.
Fujitsu Australia

---

From: Michael Paquier <[email-masked]>
Date: Wed, 18 Mar 2026 11:08:53 +0900

> Is this a tiny typo on the CLUSTER docs page?

It is.  Except if Alvaro thinks otherwise, I am putting that into my
bag of HEAD-only typos.
--
Michael

---

From: Bruce Momjian <[email-masked]>
Date: Tue, 17 Mar 2026 22:39:49 -0400

> It is.  Except if Alvaro thinks otherwise, I am putting that into my

Wow, good, catch, I didn't know this:

	https://owl.purdue.edu/owl/general_writing/grammar/using_articles.html
	
	a + singular noun beginning with a consonant sound: a user (sounds
	like 'yoo-zer,' i.e. begins with a consonant 'y' sound, so 'a'
	is used); a university; a unicycle

-- 
  Bruce Momjian  <[email-masked]>        https://momjian.us
  EDB                                      https://enterprisedb.com

  Do not let urgent matters crowd out time for investment in the future.

---

From: Michael Paquier <[email-masked]>
Date: Wed, 18 Mar 2026 13:56:47 +0900

> 	is used); a university; a unicycle

(English teachers in France are very noisy about all these grammar
rules in middle school.)

FYI, we have also this pearl in the tree, as of HEAD:
src/test/modules/test_extensions/t/001_extension_control_path.pl:
# Create an user to test permissions to read extension locations.

:D
--
Michael

---

From: Peter Smith <[email-masked]>
Date: Tue, 7 Apr 2026 15:35:08 +1000

> It is.  Except if Alvaro thinks otherwise, I am putting that into my

Did my tiny patch get lost in the bottom of your bag?

======
Kind Regards,
Peter Smith.
Fujitsu Australia

---

From: Peter Smith <[email-masked]>
Date: Tue, 7 Apr 2026 15:46:51 +1000

> Did my tiny patch get lost in the bottom of your bag?

FWIW, here [1] is a similar typo in a code comment where "a upper
bound" should say "an upper bound"

======
[1] https://github.com/postgres/postgres/blob/master/src/backend/replication/logical/worker.c#L4983

Kind Regards,
Peter Smith.
Fujitsu Australia

---

From: Michael Paquier <[email-masked]>
Date: Tue, 7 Apr 2026 15:11:32 +0900

> Did my tiny patch get lost in the bottom of your bag?

It's on one of my staging branches.  No worries.
--
Michael

---

From: Michael Paquier <[email-masked]>
Date: Tue, 7 Apr 2026 15:29:28 +0900

> bound" should say "an upper bound"

Thanks, grabbed.
--
Michael

---

From: Peter Smith <[email-masked]>
Date: Tue, 21 Apr 2026 16:51:55 +1000

> > bound" should say "an upper bound"

Thanks for pushing.

======
Kind Regards.
Peter Smith.
Fujitsu Australia