Subject: Remove commented-out code in 026_overwrite_contrecord.pl

From: Imran Zaheer <[email-masked]>
Date: Fri, 3 Apr 2026 18:56:01 +0500

Hi

There is some unused commented line of code in the tap test file `
026_overwrite_contrecord.pl` [1]. Looks like a left over from earlier test
development.

Remove it for clarity.

Thanks,
Imran Zaheer

[1]:
https://github.com/postgres/postgres/blob/b7b27eb41a5cc0b45a1a9ce5c1cde5883d7bc358/src/test/recovery/t/026_overwrite_contrecord.pl#L61
From 5eedaf7fd3c69516091a53ee281056320d3f5b21 Mon Sep 17 00:00:00 2001
From: Imran Zaheer <[email-masked]>
Date: Fri, 3 Apr 2026 18:31:03 +0500
Subject: [PATCH v1] Remove commented code in 026_overwrite_contrecord

This commented-out CREATE TABLE statement appears to be a leftover from
earlier test development and is not used in the test. Remove it for clarity.
---
 src/test/recovery/t/026_overwrite_contrecord.pl | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/src/test/recovery/t/026_overwrite_contrecord.pl b/src/test/recovery/t/026_overwrite_contrecord.pl
index 4f501169f42..82567ca6bfc 100644
--- a/src/test/recovery/t/026_overwrite_contrecord.pl
+++ b/src/test/recovery/t/026_overwrite_contrecord.pl
@@ -58,7 +58,7 @@ my $initfile = $node->safe_psql('postgres',
 $node->safe_psql('postgres',
 	qq{SELECT pg_logical_emit_message(true, 'test 026', repeat('xyzxz', 123456))}
 );
-#$node->safe_psql('postgres', qq{create table foo ()});
+
 my $endfile = $node->safe_psql('postgres',
 	'SELECT pg_walfile_name(pg_current_wal_insert_lsn())');
 ok($initfile ne $endfile, "$initfile differs from $endfile");
-- 
2.34.1

---

From: vignesh C <[email-masked]>
Date: Mon, 6 Apr 2026 15:10:50 +0530

On Fri, 3 Apr 2026 at 19:26, Imran Zaheer <[email-masked]> wrote:
>
> Hi
>
> There is some unused commented line of code in the tap test file `026_overwrite_contrecord.pl` [1]. Looks like a left over from earlier test development.

I agree with you, +1 to remove this.

Regards,
Vignesh

---

From: Michael Paquier <[email-masked]>
Date: Wed, 8 Apr 2026 11:17:30 +0900

> I agree with you, +1 to remove this.

Thanks.  This is cosmetic, so I have grabbed that for later, saved it
on a staging branch with a bunch of other things.
--
Michael