Received: from malur.postgresql.org ([217.196.149.56]) by arkaria.postgresql.org with esmtps (TLS1.3) tls TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384 (Exim 4.96) (envelope-from ) id 1wY3jp-0002aA-23 for pgsql-hackers@arkaria.postgresql.org; Fri, 12 Jun 2026 15:24:05 +0000 Received: from localhost ([127.0.0.1] helo=malur.postgresql.org) by malur.postgresql.org with esmtp (Exim 4.96) (envelope-from ) id 1wY3ip-000tJp-1R for pgsql-hackers@arkaria.postgresql.org; Fri, 12 Jun 2026 15:23:03 +0000 Received: from magus.postgresql.org ([2a02:c0:301:0:ffff::29]) by malur.postgresql.org with esmtps (TLS1.3) tls TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384 (Exim 4.96) (envelope-from ) id 1wY3ip-000tJg-06 for pgsql-hackers@lists.postgresql.org; Fri, 12 Jun 2026 15:23:03 +0000 Received: from relay6-d.mail.gandi.net ([217.70.183.198]) by magus.postgresql.org with esmtps (TLS1.3) tls TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384 (Exim 4.98.2) (envelope-from ) id 1wY3in-000000002OG-00zv for pgsql-hackers@postgresql.org; Fri, 12 Jun 2026 15:23:02 +0000 Received: by mail.gandi.net (Postfix) with ESMTPSA id 0DEC53F52F; Fri, 12 Jun 2026 15:22:58 +0000 (UTC) DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=vondra.me; s=gm1; t=1781277779; h=from:from:reply-to:subject:subject:date:date:message-id:message-id: to:to:cc:cc:mime-version:mime-version:content-type:content-type: content-transfer-encoding:content-transfer-encoding: in-reply-to:in-reply-to:references:references; bh=s0e5OtRNMz8Z0jduVpRyQdsrANjqcecM76fEDY/DNpY=; b=HHWur0EIZGnwSxkNy+YwcHWLjT+kS12lutcTajzy8TwQkxu+9QF8G/AZOkqZNRKp6/9ROn cXSU1+eIe+DokLcDBLrg6PnqfqgEsTYItrmY6/mLV9DeSa0FS8Wjc5gPEVxbnpg2mCRX/J Sl5LkZgVnubeo3O9yzJG8H2MUDbXLRCX9BZgQ2gbUH81Ig6g2v2ChH1y9wUOevSlFkHjSW NEET8/g+j6a6M/K6cwUzzYtJu2NdnornMRVojLRfW84tKFjkDFfGnONu52gZFKBEtZcGL5 4OZQRqxx9Vrkbn9bzVzsT4AcFvKd9+LW1UsFIyKz7bmv3iLMqLWixnXpQMlTaQ== Message-ID: Date: Fri, 12 Jun 2026 17:22:58 +0200 MIME-Version: 1.0 User-Agent: Mozilla Thunderbird Subject: Re: s/pg_attribute_always_inline/pg_always_inline/? To: Peter Geoghegan , Andres Freund Cc: Peter Eisentraut , pgsql-hackers@postgresql.org References: <56def459-2b95-42bc-b4e4-26e57f08b064@eisentraut.org> Content-Language: en-US From: Tomas Vondra In-Reply-To: Content-Type: text/plain; charset=UTF-8 Content-Transfer-Encoding: 8bit X-GND-Sasl: tomas@vondra.me X-GND-Cause: dmFkZTF/0JQVWS2uRnnyyTUV81BvNnh1t81pty7tUSNe/LhonF/SqMo5l2PJNVh7ixfGxVoBG30ZdAoPnpNa1d33wu1Bun8UE8blhUieRJ9SYSBYpLLvKC3LslYzPcCosGwmkyjhBXnDKtzR/KjdyfRmAqD6TQaD0C11BzpA3Dh/bM5bKBN84uEoJ/D4RGYk5Q5XXQPVbxjyzbtVYOIsi/fn5CgmMis9P/WMWirh7UhRWqHdgahre62eNmxhcFxbhTWOIYyU+UbQDLLoRTgZroOivw9wWV+olBPT4dVIzLYo95Lf2bQUcPIy5HQlcE2w96eP2z9U3FJZ3K/e0XDQuPvXLQXnTh8lM8Q60gGiPHvw7yaWmIftFBEfT7N/LL/vq5m/TnTuPs6J94vBIY7xDheuJzTVK94ZQz2jF0T0/L9aHWThMu+GxCaoRbZo7Q2fvsgE4TTMIYl8WKRB0T4DCfyF+HGVE4ORpNTOnj68FzJaeM9hdvzHeplbEHMiTsQA3oWUFxJYzgZw1fVej5Rj/u7/gOb24H4YyjTslXgkcZAcsuIMVDJTF2vxfr2wojUP9Taw7XPy5Q+FecSOVOkqmcFWCMbTv+yMTBENByCU7RV8+XO/3nRLRUk9T4hAMnsz6KBxkgAaZDYfBUximL0N/hOwwYD0voULY9jxwfWpRCQp9pV6OA X-GND-State: clean X-GND-Score: -100 List-Id: List-Help: List-Subscribe: List-Post: List-Owner: List-Archive: Archived-At: Precedence: bulk On 5/28/26 00:17, Peter Geoghegan wrote: > On Thu, Apr 9, 2026 at 10:40 AM Andres Freund wrote: >> Created a CF entry, to reduce the chances of me forgetting about committing >> this early in the 20 cycle. > > We already have a pg_noinline. How about renaming > pg_attribute_always_inline to pg_mustinline? That is an alternative > that is both consistent with pg_noinline, and even terser than your > proposal. > I agree we should shorten pg_attribute_always_inline, it's way too verbose. And other attributes don't include the _attribute_ either (like the pg_noinline mentioned here). I'm not sure about pg_mustinline. It seems weird to me, and I'm not sure saving the 3 characters is worth it, pg_always_inline seems better. > I have no intention of holding this patch up with bikeshedding. But I > noticed that even your proposed pg_always_inline rename still leaves > function prototypes over the column limit with moderately verbose > function names. It seems better to avoid that outcome. > Yeah, we should not do such weird stuff just because of unnecessarily long attribute names. Question - do we plan to do this in master only, or was the plan to backpatch the change? I'm not sure if these labels are used outside the core code, that might be an issue for backpatching. regards -- Tomas Vondra