Subject: Fix typo in import_pg_statistic() comment

From: Ilia Evdokimov <[email-masked]>
Date: Thu, 9 Apr 2026 16:02:55 +0300

Hi hackers,

There is a small typo in a comment for import_pg_statistic(): "swicthed" 
-> "switched".

This patch fixes it.

-- 
Best regards,
Ilia Evdokimov,
Tantor Labs LLC,
https://tantorlabs.com/
From b2528f67f03b3489750219d2ab7a209814f4f774 Mon Sep 17 00:00:00 2001
From: Evdokimov Ilia <[email-masked]>
Date: Thu, 9 Apr 2026 16:01:46 +0300
Subject: [PATCH v1] There is a small typo in a comment for
 import_pg_statistic(): "swicthed" -> "switched".

---
 src/backend/statistics/extended_stats_funcs.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/src/backend/statistics/extended_stats_funcs.c b/src/backend/statistics/extended_stats_funcs.c
index 9279904b465..0b8f149938c 100644
--- a/src/backend/statistics/extended_stats_funcs.c
+++ b/src/backend/statistics/extended_stats_funcs.c
@@ -1091,7 +1091,7 @@ array_in_safe(FmgrInfo *array_in, const char *s, Oid typid, int32 typmod,
  * still return a legit tuple datum.
  *
  * Set pg_statistic_ok to true if all of the values found in the container
- * were imported without issue.  pg_statistic_ok is swicthed to "true" once
+ * were imported without issue.  pg_statistic_ok is switched to "true" once
  * the full pg_statistic tuple has been built and validated.
  */
 static Datum
-- 
2.34.1

---

From: Michael Paquier <[email-masked]>
Date: Fri, 10 Apr 2026 13:37:30 +0900

On Thu, Apr 09, 2026 at 04:02:55PM +0300, Ilia Evdokimov wrote:
> There is a small typo in a comment for import_pg_statistic(): "swicthed" ->
> "switched".

Thanks.  Grabbed this one for later.
--
Michael