Subject: vacuum_cost_limit doc description patch

From: Martín Marqués <[email-masked]>
Date: Tue, 10 Apr 2018 18:13:48 -0300

Hi,

Today looking for information on hard limits for
autovacuum_vacuum_cost_limit I found myself with a very short
description in the docs.

This is a patch to add some further description, plus the upper and
lower limits it has.

-- 
Martín Marqués
select 'martin.marques' || '@' || 'gmail.com'
DBA, Programador, Administrador
From 3a1aa5de682ee6f6cbd1086845ce845409156186 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Mart=C3=ADn=20Marqu=C3=A9s?=
 <[email-masked]>
Date: Tue, 10 Apr 2018 18:03:52 -0300
Subject: [PATCH] Describe better vacuum_cost_limit, mentioning the lower and
 upper values it can take.

---
 doc/src/sgml/config.sgml | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

diff --git a/doc/src/sgml/config.sgml b/doc/src/sgml/config.sgml
index 5d5f2d23c4..fe7a6d91df 100644
--- a/doc/src/sgml/config.sgml
+++ b/doc/src/sgml/config.sgml
@@ -1860,8 +1860,9 @@ include_dir 'conf.d'
        </term>
        <listitem>
         <para>
-         The accumulated cost that will cause the vacuuming process to sleep.
-         The default value is 200.
+         This is the accumulated cost that will cause the vacuuming process to sleep
+         for vacuum_cost_delay. The parameter can take a value between 1 and 10000.
+         The default is 200.
         </para>
        </listitem>
       </varlistentry>
-- 
2.13.6

---

From: David Rowley <[email-masked]>
Date: Wed, 11 Apr 2018 17:04:33 +1200

Hi,

+         for vacuum_cost_delay. The parameter can take a value
between 1 and 10000.

vacuum_cost_delay should be in <varname> tags.

+1 to mentioning that we sleep for vacuum_cost_delay, but I just don't
see many other GUCs with mention of their supported range.

effective_io_concurrency mentions the range it supports, but this
happens to depend on USE_POSIX_FADVISE, which if undefined the maximum
setting is 0, which means the docs are wrong in some cases on that.

vacuum_cost_limit seems fairly fixed at 0-10000 with no compile-time
conditions, so perhaps it's okay, providing we remember and update the
docs if that ever changes.

-- 
 David Rowley                   http://www.2ndQuadrant.com/
 PostgreSQL Development, 24x7 Support, Training & Services

---

From: Martín Marqués <[email-masked]>
Date: Fri, 13 Apr 2018 09:56:18 -0300

> see many other GUCs with mention of their supported range.

Thanks David for having a look.

New version attached with the missing <varname> tags.

> docs if that ever changes.

I'm also adding a second patch over the config.sgml doc to fix what I
believe is a misguidance in the minimum resolution time modern systems have.

The patch just changes *many* for *some* systems which have a minimum
resolution time of 10 milliseconds.

-- 
Martín Marqués                http://www.2ndQuadrant.com/
PostgreSQL Development, 24x7 Support, Training & Services