Subject: Re: First draft of PG 19 release notes

From: "彭冲" <[email-masked]>
Date: Fri, 29 May 2026 11:30:28 +0800

Hi, Bruce

```

                    <listitem&gt; <para&gt; Modify pg_read_all_data() and pg_write_all_data() to read/write large objects (Nitin Motiani, Nathan Bossart) <ulink url="&amp;commit_baseurl;d98197602"&gt;&amp;sect;</ulink&gt; </para&gt; <para&gt; These functions are designed to allow non-super users to run pg_dump. </para&gt; </listitem&gt;```
I found the feature description is inaccurate.: “pg_read_all_data” and “pg_write_all_data” are system roles.

Besides, i think this feature should not category to Functions.

Best regards,--
Chong Peng
Yunhe Enmo（Beijing）Technology Co.,LTD
http://www.enmotech.com/

---

From: Bruce Momjian <[email-masked]>
Date: Sat, 30 May 2026 14:57:15 -0400

On Fri, May 29, 2026 at 11:30:28AM +0800, 彭冲 wrote:
> Hi, Bruce
> 
> ```
> 
> <listitem>
> <para>
> Modify pg_read_all_data() and pg_write_all_data() to read/write large objects (Nitin Motiani, Nathan Bossart)
> <ulink url="&commit_baseurl;d98197602">&sect;</ulink>
> </para>
> 
> <para>
> These functions are designed to allow non-super users to run pg_dump.
> </para>
> </listitem>
> 
> ```
> 
> 

Ah, very good point.  It item reworded and moved to the server
configuration section.  Patch attached and applied.

-- 
  Bruce Momjian  <[email-masked]>        https://momjian.us
  EDB                                      https://enterprisedb.com

  Do not let urgent matters crowd out time for investment in the future.
commit 3e744cc745b
Author: Bruce Momjian <[email-masked]>
Date:   Sat May 30 14:55:32 2026 -0400

    doc PG 19 relnotes:  adjust pg_read_all_data & pg_write_all_data
    
    These were previously marked as functions, not roles, and were in the
    wrong section.
    
    Reported-by: 彭冲 <[email-masked]>
    
    Discussion: https://postgr.es/m/[email-masked]

diff --git a/doc/src/sgml/release-19.sgml b/doc/src/sgml/release-19.sgml
index 6378542b455..ee063d2417e 100644
--- a/doc/src/sgml/release-19.sgml
+++ b/doc/src/sgml/release-19.sgml
@@ -1298,6 +1298,22 @@ This is an improved version of PQAUTHDATA_OAUTH_BEARER_TOKEN by adding the issue
 </para>
 </listitem>
 
+<!--
+Author: Nathan Bossart <[email-masked]>
+2026-02-23 [d98197602] Allow pg_{read,write}_all_data to access large objects.
+-->
+
+<listitem>
+<para>
+Allow roles pg_read_all_data and pg_write_all_data to read/write large objects (Nitin Motiani, Nathan Bossart)
+<ulink url="&commit_baseurl;d98197602">&sect;</ulink>
+</para>
+
+<para>
+These roles are designed to allow non-super users to run pg_dump.
+</para>
+</listitem>
+
 <!--
 Author: Michael Paquier <[email-masked]>
 2026-01-06 [f1e251be8] Allow bgworkers to be terminated for database-related co
@@ -2265,22 +2281,6 @@ The Dutch stemmer has also been updated.  The old Dutch stemmer is available via
 </para>
 </listitem>
 
-<!--
-Author: Nathan Bossart <[email-masked]>
-2026-02-23 [d98197602] Allow pg_{read,write}_all_data to access large objects.
--->
-
-<listitem>
-<para>
-Modify pg_read_all_data() and pg_write_all_data() to read/write large objects (Nitin Motiani, Nathan Bossart)
-<ulink url="&commit_baseurl;d98197602">&sect;</ulink>
-</para>
-
-<para>
-These functions are designed to allow non-super users to run pg_dump.
-</para>
-</listitem>
-
 <!--
 Author: Andrew Dunstan <[email-masked]>
 2026-04-05 [76e514ebb] Add pg_get_role_ddl() function