Subject: Re: First draft of PG 19 release notes

From: Chao Li <[email-masked]>
Date: Tue, 26 May 2026 13:25:15 +0800

> On May 16, 2026, at 01:27, Bruce Momjian <[email-masked]> wrote:
> 
> On Fri, May 15, 2026 at 12:31:59PM -0400, Peter Geoghegan wrote:
>> On Tue, Apr 14, 2026 at 9:19 PM Bruce Momjian <[email-masked]> wrote:
>>> I have completed the first draft of the PG 19 release notes:
>>> 
>>>        https://www.postgresql.org/docs/devel/release-19.html
>> 
>> I do not think that this item merits mention in the release notes:
>> 
>> "Add fake LSN support to hash index AM (Peter Geoghegan)"
>> 
>> It offers no user-visible benefit. It's just preparation for index
>> prefetching, which didn't make it into Postgres 19.
> 
> Ah, I see your point, and the commit message was clear:
> 
>    This commit is similar to commit 8a879119, which taught nbtree to
>    use fake LSNs to improve its dropPin behavior.  However, unlike that
>    commit, this is not an independently useful enhancement, since hash
>    doesn't implement anything like nbtree's dropPin behavior (not yet).
> 
> Item removed.
> 
> -- 
>  Bruce Momjian  <[email-masked]>        https://momjian.us
>  EDB                                      https://enterprisedb.com
> 
>  Do not let urgent matters crowd out time for investment in the future.
> 
> 

Chong Peng, whom I added to CC, reported this release note issue to me, so I’m just forwarding the message:

```
<listitem>
<para>
Add slot synchronization skip information to pg_stat_replication_slots (Shlok Kyal)
<ulink url="&commit_baseurl;76b78721c">&sect;</ulink>
<ulink url="&commit_baseurl;e68b6adad">&sect;</ulink>
<ulink url="&commit_baseurl;5db6a344a">&sect;</ulink>
</para>

<para>
The new columns are slotsync_skip_count, slotsync_last_skip, and slotsync_skip_reason.
</para>
</listitem>
```

The feature description is inaccurate: slotsync_skip_count and slotsync_last_skip belong to pg_stat_replication_slots, while slotsync_skip_reason belongs to pg_replication_slots. Maybe it could be reworded as:
```
Add slot synchronization skip information to pg_stat_replication_slots and pg_replication_slots (Shlok Kyal)
```

Best regards,
--
Chao Li (Evan)
HighGo Software Co., Ltd.
https://www.highgo.com/

---

From: Bruce Momjian <[email-masked]>
Date: Tue, 26 May 2026 11:00:21 -0400

> Add slot synchronization skip information to pg_stat_replication_slots and pg_replication_slots (Shlok Kyal)

Yes, very good point.  I missed that detail when merging the commit
items.  I fixed it as you suggested, patch attached.

  Do not let urgent matters crowd out time for investment in the future.
diff --git a/doc/src/sgml/release-19.sgml b/doc/src/sgml/release-19.sgml
index c8f2b3c6968..f0911b86005 100644
--- a/doc/src/sgml/release-19.sgml
+++ b/doc/src/sgml/release-19.sgml
@@ -1634,7 +1634,7 @@ Author: Amit Kapila <[email-masked]>
 
 <listitem>
 <para>
-Add slot synchronization skip information to pg_stat_replication_slots (Shlok Kyal)
+Add slot synchronization skip information to pg_stat_replication_slots and pg_replication_slots (Shlok Kyal)
 <ulink url="&commit_baseurl;76b78721c">&sect;</ulink>
 <ulink url="&commit_baseurl;e68b6adad">&sect;</ulink>
 <ulink url="&commit_baseurl;5db6a344a">&sect;</ulink>

---

From: Thom Brown <[email-masked]>
Date: Tue, 26 May 2026 16:46:12 +0100

> items.  I fixed it as you suggested, patch attached.

Did a review and found a few issues. Attached fixes.

Regards

Thom
diff --git a/doc/src/sgml/release-19.sgml b/doc/src/sgml/release-19.sgml
index f0911b86005..9aae934215a 100644
--- a/doc/src/sgml/release-19.sgml
+++ b/doc/src/sgml/release-19.sgml
@@ -77,7 +77,7 @@ Issue a warning after successful MD5 password authentication (Nathan Bossart)
 </para>
 
 <para>
-The warning can be disabled via server variable md5_password_warnings.  MD5 passwords were marked marked as deprecated in Postgres 18.
+The warning can be disabled via server variable md5_password_warnings.  MD5 passwords were marked as deprecated in Postgres 18.
 </para>
 </listitem>
 
@@ -144,7 +144,7 @@ Change the default index opclasses for inet and cidr data types from btree_gist
 </para>
 
 <para>
-The btree_gist inet/cidr opclasses are broken because they can exclude rows that should be returned.  Pg_upgrade will fail to upgrade if btree_gist inet/cidr indexes exist in the old
+The btree_gist inet/cidr opclasses are broken because they can exclude rows that should be returned.  pg_upgrade will fail to upgrade if btree_gist inet/cidr indexes exist in the old
 server.
 </para>
 </listitem>
@@ -328,7 +328,7 @@ Author: Richard Guo <[email-masked]>
 
 <listitem>
 <para>
-Allow NOT INs to be converted to more efficient ANTI JOINs when NULLs are not present (Richard Guo)
+Allow NOT IN clauses to be converted to more efficient anti-joins when NULLs are not present (Richard Guo)
 <ulink url="&commit_baseurl;383eb21eb">&sect;</ulink>
 </para>
 </listitem>
@@ -700,7 +700,7 @@ Author: Nathan Bossart <[email-masked]>
 
 <listitem>
 <para>
-Improve COPY FROM performance for text and CSV output using SIMD CPU instructions (Nazir Bilal Yavuz, Shinya Kato)
+Improve COPY FROM performance for text and CSV input using SIMD CPU instructions (Nazir Bilal Yavuz, Shinya Kato)
 <ulink url="&commit_baseurl;e0a3a3fd5">&sect;</ulink>
 </para>
 </listitem>
@@ -1210,7 +1210,7 @@ Author: Nathan Bossart <[email-masked]>
 
 <listitem>
 <para>
-Issue warnings when the wraparound of xid and multi-xids is less then 100 million (Nathan Bossart)
+Issue warnings when the wraparound of xid and multi-xids is less than 100 million (Nathan Bossart)
 <ulink url="&commit_baseurl;48f11bfa0">&sect;</ulink>
 </para>
 
@@ -1588,7 +1588,7 @@ Add subscription option max_retention_duration to limit retain_dead_tuples reten
 </para>
 
 <para>
-When the limit is reached, dead tuple retention until manually re-enabled or a new subscription is created.
+When the limit is reached, dead tuple retention is disabled until manually re-enabled or a new subscription is created.
 </para>
 </listitem>

---

From: Bruce Momjian <[email-masked]>
Date: Tue, 26 May 2026 16:32:47 -0400

> Did a review and found a few issues. Attached fixes.

Oh, all very good, applied, thanks.

---

From: Thom Brown <[email-masked]>
Date: Tue, 26 May 2026 22:14:32 +0100

> Oh, all very good, applied, thanks.

I've just spotted that this was a slightly older version of the patch
I had accidentally selected. Attached are the missing changes I had
intended to also send.

Regards

Thom
diff --git a/doc/src/sgml/release-19.sgml b/doc/src/sgml/release-19.sgml
index 9aae934215a..6378542b455 100644
--- a/doc/src/sgml/release-19.sgml
+++ b/doc/src/sgml/release-19.sgml
@@ -218,12 +218,12 @@ This means READ ONLY transactions can no longer modify rows processed by postgre
 
 <!--
 Author: Heikki Linnakangas <[email-masked]>
-2026-04-03 [79534f906] Change default of max_locks_per_transactions to 128
+2026-04-03 [79534f906] Change default of max_locks_per_transaction to 128
 -->
 
 <listitem>
 <para>
-Change default of max_locks_per_transactions from 64 to 128 (Heikki Linnakangas)
+Change default of max_locks_per_transaction from 64 to 128 (Heikki Linnakangas)
 <ulink url="&commit_baseurl;79534f906">&sect;</ulink>
 </para>
 
@@ -1619,7 +1619,7 @@ Rename column sync_error_count to sync_table_error_count in system view pg_stat_
 </para>
 
 <para>
-This is necessary since sequences errors are now also tracked.
+This is necessary since sequence errors are now also tracked.
 </para>
 </listitem>
 
@@ -1747,7 +1747,7 @@ Author: Dean Rasheed <[email-masked]>
 
 <listitem>
 <para>
-Add support for INSERT ... ON CONFLICT DO SELECT ... RETURNING (Andreas Karlsson,  Marko Tiikkaja, Viktor Holmberg)
+Add support for INSERT ... ON CONFLICT DO SELECT ... RETURNING (Andreas Karlsson, Marko Tiikkaja, Viktor Holmberg)
 <ulink url="&commit_baseurl;88327092f">&sect;</ulink>
 </para>
 
@@ -1798,7 +1798,7 @@ Allow REPACK to rebuild tables without access-exclusive locking (Antonin Houska,
 </para>
 
 <para>
-This is enabled via the CONCURRENTLY option.  Server variables max_repack_replication_slots was also added.
+This is enabled via the CONCURRENTLY option.  Server variable max_repack_replication_slots was also added.
 </para>
 </listitem>
 
@@ -1961,7 +1961,7 @@ Author: Fujii Masao <[email-masked]>
 
 <listitem>
 <para>
-Allow multiple headers lines be skipped by COPY FROM (Shinya Kato, Fujii Masao)
+Allow multiple headers lines to be skipped by COPY FROM (Shinya Kato, Fujii Masao)
 <ulink url="&commit_baseurl;bc2f348e8">&sect;</ulink>
 </para>
 
@@ -2217,7 +2217,7 @@ Add functions to return a set of ranges resulting from range subtraction (Paul A
 </para>
 
 <para>
-The functions are range_minus_multi() and multirange_minus_multi().  This is useful to represent range subtractions results with gaps.
+The functions are range_minus_multi() and multirange_minus_multi().  This is useful to represent range subtraction results with gaps.
 </para>
 </listitem>
 
@@ -2245,7 +2245,7 @@ Allow IS JSON to work on domains defined over supported base types (Jian He)
 </para>
 
 <para>
-The supported base domains are TEXT, JSON, JSONB, and BYTEA.
+The supported base types are TEXT, JSON, JSONB, and BYTEA.
 </para>
 </listitem>
 
@@ -2424,7 +2424,7 @@ Author: Jacob Champion <[email-masked]>
 
 <listitem>
 <para>
-Allow libpq environment variable PGOAUTHDEBUG to specify specific debug options (Zsolt Parragi, Jacob Champion)
+Allow libpq environment variable PGOAUTHDEBUG to specify particular debug options (Zsolt Parragi, Jacob Champion)
 <ulink url="&commit_baseurl;6d00fb904">&sect;</ulink>
 </para>
 
@@ -2690,7 +2690,7 @@ Author: Andrew Dunstan <[email-masked]>
 
 <listitem>
 <para>
-Allow pg_dumpall to product output in non-text formats (Mahendra Singh Thalor, Andrew Dunstan)
+Allow pg_dumpall to produce output in non-text formats (Mahendra Singh Thalor, Andrew Dunstan)
 <ulink url="&commit_baseurl;763aaa06f">&sect;</ulink>
 <ulink url="&commit_baseurl;3c19983cc">&sect;</ulink>
 </para>

---

From: Bruce Momjian <[email-masked]>
Date: Tue, 26 May 2026 17:49:54 -0400

> I had accidentally selected. Attached are the missing changes I had

Wow, thanks for the additional fixes, applied.

---

From: Yugo Nagata <[email-masked]>
Date: Fri, 5 Jun 2026 17:11:08 +0900

Hi,

On Tue, 14 Apr 2026 21:18:57 -0400

> 	https://www.postgresql.org/docs/devel/release-19.html

I noticed duplicate names in the psql tab completion improvement entry.
Yugo Nagata and Fujii Masao each appear twice.

If this is not intentional, we could remove the duplicates as in the attached patch.

Regareds,
Yugo Nagata

-- 
Yugo Nagata <[email-masked]>
diff --git a/doc/src/sgml/release-19.sgml b/doc/src/sgml/release-19.sgml
index 0dd2ee580c9..52521cf37de 100644
--- a/doc/src/sgml/release-19.sgml
+++ b/doc/src/sgml/release-19.sgml
@@ -2559,7 +2559,7 @@ Author: Álvaro Herrera <[email-masked]>
 
 <listitem>
 <para>
-Add or improve <link linkend="app-psql"><application>psql</application></link> tab completion (Yamaguchi Atsuo, Yugo Nagata, Haruna Miwa, Xuneng Zhou, Yugo Nagata, Dagfinn Ilmari Mannsåker, Fujii Masao, Álvaro Herrera, Jian He, Fujii Masao,
+Add or improve <link linkend="app-psql"><application>psql</application></link> tab completion (Yamaguchi Atsuo, Yugo Nagata, Haruna Miwa, Xuneng Zhou, Dagfinn Ilmari Mannsåker, Fujii Masao, Álvaro Herrera, Jian He,
 Tatsuya Kawata, Ian Lawrence Barwick, Vasuki M)
 <ulink url="&commit_baseurl;5fa7837d9">&sect;</ulink>
 <ulink url="&commit_baseurl;c6a7d3bab">&sect;</ulink>

---

From: Bruce Momjian <[email-masked]>
Date: Fri, 5 Jun 2026 09:55:27 -0400

> If this is not intentional, we could remove the duplicates as in the attached patch.

Yes, my mistake, will fix, thanks.

---

From: Bruce Momjian <[email-masked]>
Date: Fri, 5 Jun 2026 14:14:21 -0400

> Yes, my mistake, will fix, thanks.

I want to thank everyone for the fixes/improvements they have supplied
for the PG 19 release notes.  I am now satisfied with them and I think
they are close to what they will look link for PG 19 final. Here are the
current contents:

	https://www.postgresql.org/docs/19/release-19.html

---

From: Bruce Momjian <[email-masked]>
Date: Fri, 5 Jun 2026 14:58:41 -0400

> 	https://www.postgresql.org/docs/19/release-19.html

My apologies, this is the old version;  the most current version is
here:

	https://momjian.us/pgsql_docs/release-19.html

---

From: Baji Shaik <[email-masked]>
Date: Fri, 5 Jun 2026 14:17:01 -0500

>         https://momjian.us/pgsql_docs/release-19.html

Can e5035950dab ("psql: Fix tab completion for REPACK boolean options")
also be part of the notes?
https://git.postgresql.org/gitweb/?p=postgresql.git;a=commit;h=e5035950dab

---

From: Bruce Momjian <[email-masked]>
Date: Fri, 5 Jun 2026 15:29:17 -0400

> https://git.postgresql.org/gitweb/?p=postgresql.git;a=commit;h=e5035950dab

Uh, I don't add tab fixes for new commands in the release note.  I am
more focused on adding changes for tab completion for existing commands,
though I tend to add them on the first pass but not in later months.

---

From: Álvaro Herrera <[email-masked]>
Date: Sat, 6 Jun 2026 15:08:05 +0200

> 	https://momjian.us/pgsql_docs/release-19.html

Thanks for putting these together!  I have a few comments:

* In the incompatibilities section, we have
  - Prevent carriage returns and line feeds in database, role, and
  tablespace names

  This was changed to avoid security problems. pg_upgrade will also
  disallow upgrading of clusters that use such names.

  The verb "prevent" here is a bit strange; I think "reject" would be
  better.  Also, I think the phrase involving pg_upgrade should come
  before the reason for the change.

  We also have this item:

  Change the default index opclasses for inet and cidr data types from
  btree_gist to GiST

  The btree_gist inet/cidr opclasses are broken because they can exclude
  rows that should be returned. pg_upgrade will fail to upgrade if
  btree_gist inet/cidr indexes exist in the old server.

  Why do we say "pg_upgrade will fail to upgrade" here instead of the
  (IMO better) wording in the previous item?  That is, "pg_upgrade will
  disallow upgrading if btree_gist inet/cidr indexes exist in the old
  server".  The current wording of "fail to" suggest that this is a
  pg_upgrade shortcoming, which it isn't.

* In section E.1.3.1.1 Optimizer, I think the item
  "Allow extended statistics on virtual generated columns"
  should come before all other items, because it's the only one that
  requires user action in order for them to take advantage of it.  All
  the other items refer to some optimization that occurs automatically.

* Section E.1.3.1.2 General Performance, the item
  Allow autovacuum to use parallel vacuum workers
  lacks a link to
  https://momjian.us/pgsql_docs/sql-createtable.html#RELOPTION-AUTOVACUUM-PARALLEL-WORKERS

* Section E.1.3.1.3 System Views, the two items
  Add vacuum initiation details to system view pg_stat_progress_vacuum
  Add analyze initiation details to system view pg_stat_progress_analyze
  Maybe they should be a single entry?
  Add vacuum and analyze initiation details to system view
  pg_stat_progress_vacuum and pg_stat_progress_analyze respectively
  (Not really sure about this one)
 
* E.1.3.1.4 Monitoring
  Add server variable log_autoanalyze_min_duration to log long-running
  autoanalyze operations (Shinya Kato) §
  Server variable log_autovacuum_min_duration now only controls logging
  of autovacuum operations.

  I think it's confusing to talk about "autoanalyze" as if it were
  an action taken by an agent other than autovacuum.  I mean, we have
  autovacuum which runs autovacuums and also autovacuum which runs
  autoanalyzes?  To my mind that makes no sense -- I think we have one
  autovacuum, which runs vacuum and analyze.

  I would explain this as
  Add server variable log_autoanalyze_min_duration to log long-running
  analyze operations run by autovacuum (Shinya Kato) §
  Server variable log_autovacuum_min_duration now only controls logging
  of vacuum operations run by autovacuum.

  * Add WAL full-page write bytes reporting to VACUUM and ANALYZE logging
  (Shinya Kato) §
  Maybe this should be "Report bytes of full-page WAL writes to VACUUM
  and ANALYZE logging".
  (This also appears in E.1.3.3.3 EXPLAIN and E.1.3.1.3 System Views)

  * Add function pg_get_multixact_stats() to report multixact activity
  (Naga Appani) §
  I think this item should appear second in the section, right after the
  one for log_min_messages, on importance grounds.

  * Two entries make the acronym LSN point to 
  https://momjian.us/pgsql_docs/wal-internals.html
  I think a better target is the glossary item
  https://momjian.us/pgsql_docs/glossary.html#GLOSSARY-LOG-SEQUENCE-NUMBER
  The shorter definition in the glossary is possibly more useful for a
  release note reader; and if they want even more detail, the glossary
  definition does point to the WAL internals.
  A third entry appears in E.1.3.1.6

* E.1.3.1.5 Server Configuration
  * Allow online enabling and disabling of data checksums
  Previously the checksum status could only be set at initialization and
  changed only while the cluster was offline using pg_checksums.

  The word "only" appears twice in the second phrase, which is awkward.
  Maybe reword it as
  Previously the checksum status would be fixed at initialization time and
  only changed while the cluster was offline usiNG PG_checksums.

  * Add scoring system to control the order that tables are autovacuumed
  I think using "autovacuumed" as a verb is terrible grammar.  I would
  rather have "... are processed by autovacuum".
  
  * Allow background workers to be configured to terminate before
  database-level operations (Aya Iwata) §
  This sounds far too mysterious; it probably warrants more detail.
  Also, move it a bit upwards: just below SNI perhaps?  (That isn't
  much, but all the other items in this section also look valuable.)

* E.1.3.3.2 Copy
  * Allow COPY TO to output partitioned tables (Jian He, Ajin Cherian) § §
  "to output partitioned tables"?  This reads really awkward.
  What about ... "Allow partitioned tables to be [processed / read] by
  COPY TO directly" or something like that?

-- 
Álvaro Herrera         PostgreSQL Developer  —  https://www.EnterpriseDB.com/
"La vida es para el que se aventura"

---

From: Bruce Momjian <[email-masked]>
Date: Sun, 7 Jun 2026 23:43:16 -0400

>   before the reason for the change.

Agreed.  I went with "Disallow carriage returns and line feeds", and I
moved the security text to the end as you suggested.

>   pg_upgrade shortcoming, which it isn't.

I went with similar wording "pg_upgrade will disallow upgrading".

>   the other items refer to some optimization that occurs automatically.

While the first item in each section is the most important, I then list
later items in groups that have similar characteristics, which I think
simplifies reading.  While I could order all items in importance order,
I think it would be much more confusing to read.  Right now the item you
mention is in a group of items about optimizer statistics.

>   https://momjian.us/pgsql_docs/sql-createtable.html#RELOPTION-AUTOVACUUM-PARALLEL-WORKERS

Added link.

>   (Not really sure about this one)

I looked at merging these before, and the existence of the "mode" column
in vacuum but not analyze made the merged item too complicated to
understand.

>   of vacuum operations run by autovacuum.

Well, the column calls it autoanalyze, but I agree when we are talking
about the tool, autovacuum is better, so changed.

>   (This also appears in E.1.3.3.3 EXPLAIN and E.1.3.1.3 System Views)

Yes, saying "Add reporting of X" is better than "add X reporting";  fixed
in both cases.

>   one for log_min_messages, on importance grounds.

Again, already grouped in a section about monitoring functions, and I do
think the earlier items are more important.

>   A third entry appears in E.1.3.1.6

Well, the second paragraph does explain LSN so I think pointing them to
a glossary makes things worse.

>   only changed while the cluster was offline usiNG PG_checksums.

Yes, and the bigger problem is that there is no need to mention
initialization setting of checksums, so the first part of the sentence
is now gone.

>   rather have "... are processed by autovacuum".

Yes, agreed, fixed.

>   much, but all the other items in this section also look valuable.)

Agreed.  I added a sentence to explain its purpose.

>   COPY TO directly" or something like that?

Yes, I used "process".  New output here:

You certainly found some confusing items and I like the new output.

---

From: Bruce Momjian <[email-masked]>
Date: Mon, 8 Jun 2026 10:13:33 -0400

> mention is in a group of items about optimizer statistics.

Actually, if there is no "most important" item in a section, I just
order by placing the largest group of similar items first.  Here are the
detais:

	https://wiki.postgresql.org/wiki/Creating_Major_Release_Notes
	order inside of sections
	               most important item first in section
	                  if none, then largest group first
	               group similar items together
	               order group by item importance
	               ideally the last item in a group will relate to the first item in the next group

---

From: Chao Li <[email-masked]>
Date: Tue, 9 Jun 2026 14:59:17 +0800

> On Jun 8, 2026, at 22:13, Bruce Momjian <[email-masked]> wrote:
> 

Hi Bruce,

This feature has been reverted by a0354e29c41a9fb7491b3c7c23f079b1923c045a.

```
<!--
Author: Andrew Dunstan <[email-masked]>
2026-03-12 [a0b6ef29a] Enable fast default for domains with non-volatile constr
-->

<listitem>
<para>
Allow the <link linkend="sql-altertable">addition of columns</link> based on domains containing constraints to usually avoid a table rewrite (Jian He)
<ulink url="&commit_baseurl;a0b6ef29a">&sect;</ulink>
</para>

<para>
Previously this always required a table rewrite.
</para>
</listitem>
```

So this item can be removed from the release note.

Best regards,

---

From: Srinath Reddy Sadipiralla <[email-masked]>
Date: Thu, 11 Jun 2026 14:31:38 +0530

Hi Bruce,

>         https://www.postgresql.org/docs/devel/release-19.html

Thanks for working on this.

I noticed the notes don't mention the pg_rewind improvement committed in
5173bfd0 ("pg_rewind: Skip copy of WAL segments generated before point of
divergence") [0].

[0] -
https://www.postgresql.org/message-id/flat/181b4c6fa9c.b8b725681941212.7547232617810891479%40viggy28.dev

-- 
Thanks :)
Srinath Reddy Sadipiralla
EDB: https://www.enterprisedb.com/

---

From: Bruce Momjian <[email-masked]>
Date: Tue, 16 Jun 2026 14:14:35 -0400

> So this item can be removed from the release note.

Thanks.  Reading the revert commit message, I am not sure I would have
associated it with this release note item's visible text.  Thanks.  I
updated the release notes to current.

---

From: Bruce Momjian <[email-masked]>
Date: Tue, 16 Jun 2026 19:41:23 -0400

On Thu, Jun 11, 2026 at 02:31:38PM +0530, Srinath Reddy Sadipiralla wrote:
> [0] - https://www.postgresql.org/message-id/flat/
> 181b4c6fa9c.b8b725681941212.7547232617810891479%40viggy28.dev

True.  In reading the commit message, it seems like a minor improvement
that wasn't worth mentioning;   it says:

	This commit makes the way WAL segments are handled from the source
	to the target server slightly smarter:
	                     ----------------

and

	This change can make the rewind operation cheaper in some
	configurations, especially for setups where some WAL retention
	causes many segments to remain on the source server even after the
	promotion of a standby used as source to rewind a previous primary.

It seemed like a nice improvement, but not something that would be
useful for the average user to know.

---

From: Fujii Masao <[email-masked]>
Date: Thu, 18 Jun 2026 10:29:47 +0900

> I have completed the first draft of the PG 19 release notes:

Thanks for working on the release note!

    Reduce lock level of ALTER DOMAIN ... VALIDATE CONSTRAINT to match
ALTER TABLE ... VALIDATE CONSTRAINT (Jian He) §

I reverted this change at commit 64797ad97d6, so could you please
remove this item from the release notes?

Regards,

-- 
Fujii Masao

---

From: Bruce Momjian <[email-masked]>
Date: Wed, 17 Jun 2026 21:34:38 -0400

> remove this item from the release notes?

Oh, I missed that one, removed, thanks.

---

From: Bruce Momjian <[email-masked]>
Date: Wed, 17 Jun 2026 21:45:48 -0400

> Oh, I missed that one, removed, thanks.

Ah, I missed it because it happened today and I was only current as of
yesterday.  I have now updated to be current as of today.