public inbox for [email protected]  
help / color / mirror / Atom feed
From: Álvaro Herrera <[email protected]>
To: Bertrand Drouvot <[email protected]>
To: Tom Lane <[email protected]>
Cc: Michael Paquier <[email protected]>
Cc: Chao Li <[email protected]>
Cc: L. pgsql-hackers <[email protected]>
Cc: Fujii Masao <[email protected]>
Cc: Peter Eisentraut <[email protected]>
Cc: Jeff Davis <[email protected]>
Cc: Ashutosh Bapat <[email protected]>
Cc: Amit Kapila <[email protected]>
Subject: Re: Fix unqualified catalog references in psql describe queries
Date: Wed, 10 Jun 2026 10:33:35 +0200
Message-ID: <[email protected]> (raw)
In-Reply-To: <aikBRL/Tws2vmIjI@bdtpg>
References: <[email protected]>
	<[email protected]>
	<aifYIhmiqNr9mf6f@bdtpg>
	<[email protected]>
	<[email protected]>
	<aikBRL/Tws2vmIjI@bdtpg>

On 2026-06-10, Bertrand Drouvot wrote:

> I do agree that doing so would "destroy" the readability. I did not 
> look in detail,
> but what about forcing ALWAYS_SECURE_SEARCH_PATH_SQL before the queries 
> and
> restore the search_path once the query is done? (that way that would 
> not impact
> the readability)

I think we should just ditch the idea that operators live in schemas.

-- 
Álvaro Herrera






view thread (14+ messages)  latest in thread

reply

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Reply to all the recipients using the --to and --cc options:
  reply via email

  To: [email protected]
  Cc: [email protected], [email protected], [email protected], [email protected], [email protected], [email protected], [email protected], [email protected], [email protected], [email protected], [email protected]
  Subject: Re: Fix unqualified catalog references in psql describe queries
  In-Reply-To: <[email protected]>

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

This inbox is served by agora; see mirroring instructions
for how to clone and mirror all data and code used for this inbox