Subject: Postgresql 18 Linux (all flavors) - with installation, create new instance/main database

From: Dutch Glory <[email-masked]>
Date: Thu, 7 May 2026 08:33:53 +0000 (UTC)

proposal:
Postgresql 18 Linux (all flavors) - with installation, create new instance/main database:
sudo -u postgres /usr/pgsql-18/bin/pg_ctl -D /var/lib/pgsql/18/data/ initdb

this way Postgresql is ready to use... 

_________________________________

Dank U - Thank You 

Twitter:
http://twitter.com/OpenSimFan

Facebook:
http://www.facebook.com/andre.verwijs
Instagram:
https://instagram.com/dutchglory

---

From: "David G. Johnston" <[email-masked]>
Date: Thu, 7 May 2026 05:40:39 -0700

> sudo -u postgres /usr/pgsql-18/bin/pg_ctl -D /var/lib/pgsql/18/data/ initdb
No, make/ninja install should not create a database.  That is outside its
appropriate responsibilities.  Installing from source stops once the
binaries are installed.  Using the installed product is up to the user.

David J.

---

From: Isaac Morland <[email-masked]>
Date: Thu, 7 May 2026 08:44:12 -0400

> binaries are installed.  Using the installed product is up to the user.

Also there are lots of reasons to install Postgres without creating an
instance. This is actually one of the things I don't like about the Ubuntu
installer, which defaults to creating an instance (although this behaviour
can be suppressed by creating a config file with an appropriate directive
first).

---

From: Andrew Dunstan <[email-masked]>
Date: Thu, 7 May 2026 09:35:29 -0400

On 2026-05-07 Th 8:44 AM, Isaac Morland wrote:
> On Thu, 7 May 2026 at 08:40, David G. Johnston 
> <[email-masked]> wrote:
>
>     No, make/ninja install should not create a database. That is
>     outside its appropriate responsibilities. Installing from source
>     stops once the binaries are installed.  Using the installed
>     product is up to the user.
>
>
> instance. This is actually one of the things I don't like about the 
> Ubuntu installer, which defaults to creating an instance (although 
> this behaviour can be suppressed by creating a config file with an 
> appropriate directive first).

+1 It's annoyed me many times.

cheers

andrew

--
Andrew Dunstan
EDB:https://www.enterprisedb.com

---

From: Tom Lane <[email-masked]>
Date: Thu, 07 May 2026 10:07:00 -0400

> +1 It's annoyed me many times.

Yeah.  When I was with Red Hat, there was a pretty nearly ironclad
rule that simply installing a package shouldn't cause it to do
anything.  The argument for this was that you should be able to
select fairly large package sets at system install time and not
worry about half-configured servers starting up on you.  Exceptions
were made for services that were (a) essential to system functionality
and (b) having default configurations that were both secure and
widely useful as-is.  It's impossible to argue that Postgres meets
either condition.

			regards, tom lane