Received: from malur.postgresql.org ([217.196.149.56]) by arkaria.postgresql.org with esmtps (TLS1.3) tls TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384 (Exim 4.96) (envelope-from ) id 1vhrWA-0082ll-0t for pgsql-hackers@arkaria.postgresql.org; Mon, 19 Jan 2026 15:50:14 +0000 Received: from localhost ([127.0.0.1] helo=malur.postgresql.org) by malur.postgresql.org with esmtp (Exim 4.96) (envelope-from ) id 1vhrW8-00DfG9-0G for pgsql-hackers@arkaria.postgresql.org; Mon, 19 Jan 2026 15:50:12 +0000 Received: from magus.postgresql.org ([2a02:c0:301:0:ffff::29]) by malur.postgresql.org with esmtps (TLS1.3) tls TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384 (Exim 4.96) (envelope-from ) id 1vhrW7-00DfG1-14 for pgsql-hackers@lists.postgresql.org; Mon, 19 Jan 2026 15:50:12 +0000 Received: from fhigh-b5-smtp.messagingengine.com ([202.12.124.156]) by magus.postgresql.org with esmtps (TLS1.3) tls TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384 (Exim 4.96) (envelope-from ) id 1vhrW4-001MMZ-0d for pgsql-hackers@lists.postgresql.org; Mon, 19 Jan 2026 15:50:11 +0000 Received: from phl-compute-01.internal (phl-compute-01.internal [10.202.2.41]) by mailfhigh.stl.internal (Postfix) with ESMTP id E944C7A00F7; Mon, 19 Jan 2026 10:50:04 -0500 (EST) Received: from phl-frontend-04 ([10.202.2.163]) by phl-compute-01.internal (MEProxy); Mon, 19 Jan 2026 10:50:05 -0500 DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=eisentraut.org; h=cc:content-transfer-encoding:content-type:content-type:date :date:from:from:in-reply-to:in-reply-to:message-id:mime-version :references:reply-to:subject:subject:to:to; s=fm1; t=1768837804; x=1768924204; bh=JtFaKB8wobavVY+RZIvDs/hzUppeWeKvbyfNvwK7bng=; b= Z4k5sSdizTH2g7ecAnE3J3BDJQOB8ijNj20Clavoospj80Js9l31aQl0bgUxmrDf mcPH9qVgXEtGTNvZbLBXIMHkXkbAqKFn7eTSE43w10w8S028ebmAyffmPiFydYBY 5diwF2SpfIMYce7P5EmWYjbTvNbPADLCToyP7feeB7GJeEE0DlpmGM11SjixsBv8 WPG+zKaVxI7/rVB/CMKRv7xyxsqNLHJ7JlTlIHiGLXtk/u4KoPlvgXxOWPMEOUDn LPzzJTkuG7fve8qONQ/VQv/5pcGf52UksL5f0snxpOSbs48AeyWOXskn0JxIZDcc jKHzz0nmZG8XfBm3SR4baw== DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d= messagingengine.com; h=cc:content-transfer-encoding:content-type :content-type:date:date:feedback-id:feedback-id:from:from :in-reply-to:in-reply-to:message-id:mime-version:references :reply-to:subject:subject:to:to:x-me-proxy:x-me-sender :x-me-sender:x-sasl-enc; s=fm2; t=1768837804; x=1768924204; bh=J tFaKB8wobavVY+RZIvDs/hzUppeWeKvbyfNvwK7bng=; b=jxu8cltcwdfHJ/Yhy hOH5zmfo/cS0PB7uWiW2pUC52dlpbX6P3REpXOlK7BlY/u9KMsEakmoPo26nKmnr oydiid4aR1LwcG1WFQKIV1I7WYNzgkj/tMahHyVAqIlCFlgF99K6rY0zQXsxw+nU vqxh2UAKEst5Z9aFZ+02y1OoaKnbO7YB8QJDhArqHTpAlmnhHf1pjEUy11top1py 2h9pvspQqkriTOxM7FSxdbEt1uHMw4o7H2bB84thDL5h5ucX74FH6CbLM+FaDRZU eW+YEjjEHwjY88QA5lb2Os1Bp1vr1K3wP4K076m62ej43jQrfHwK4ohx9R0+ISNZ vroZQ== X-ME-Sender: X-ME-Received: X-ME-Proxy-Cause: gggruggvucftvghtrhhoucdtuddrgeefgedrtddtgddufeejleeiucetufdoteggodetrf dotffvucfrrhhofhhilhgvmecuhfgrshhtofgrihhlpdfurfetoffkrfgpnffqhgenuceu rghilhhouhhtmecufedttdenucesvcftvggtihhpihgvnhhtshculddquddttddmnecujf gurhepkfffgggfuffvfhfhjggtgfesthekredttddvjeenucfhrhhomheprfgvthgvrhcu gfhishgvnhhtrhgruhhtuceophgvthgvrhesvghishgvnhhtrhgruhhtrdhorhhgqeenuc ggtffrrghtthgvrhhnpedugfejffefleefvdegvdejvdeiheevgffhjefgudfhvedvjeev feehteelgfevfeenucevlhhushhtvghrufhiiigvpedtnecurfgrrhgrmhepmhgrihhlfh hrohhmpehpvghtvghrsegvihhsvghnthhrrghuthdrohhrghdpnhgspghrtghpthhtohep vddpmhhouggvpehsmhhtphhouhhtpdhrtghpthhtoheplhhirdgvvhgrnhdrtghhrghose hgmhgrihhlrdgtohhmpdhrtghpthhtohepphhgshhqlhdqhhgrtghkvghrsheslhhishht shdrphhoshhtghhrvghsqhhlrdhorhhg X-ME-Proxy: Feedback-ID: ie0a040ee:Fastmail Received: by mail.messagingengine.com (Postfix) with ESMTPA; Mon, 19 Jan 2026 10:50:03 -0500 (EST) Message-ID: Date: Mon, 19 Jan 2026 16:50:01 +0100 MIME-Version: 1.0 User-Agent: Mozilla Thunderbird Subject: Re: tablecmds: clarify recurse vs recusing To: Chao Li , Postgres hackers References: Content-Language: en-US From: Peter Eisentraut In-Reply-To: Content-Type: text/plain; charset=UTF-8; format=flowed Content-Transfer-Encoding: 8bit List-Id: List-Help: List-Subscribe: List-Post: List-Owner: List-Archive: Archived-At: Precedence: bulk On 19.01.26 08:14, Chao Li wrote: > Many ALTER TABLE-related functions take two boolean parameters, > "recurse" and "recursing", whose names are easy to confuse. I'm not bothered by this. > To reduce this confusion, I’m proposing to rename "recurse" to > "no_only", which more directly reflects its meaning. This seems worse. Especially since no_only is almost a double negative.