Received: from malur.postgresql.org ([217.196.149.56]) by arkaria.postgresql.org with esmtp (Exim 4.84_2) (envelope-from ) id 1cYJyw-0005yq-89 for pgsql-hackers@arkaria.postgresql.org; Mon, 30 Jan 2017 21:59:26 +0000 Received: from localhost ([127.0.0.1] helo=postgresql.org) by malur.postgresql.org with smtp (Exim 4.84_2) (envelope-from ) id 1cYJyv-0005VZ-RU for pgsql-hackers@arkaria.postgresql.org; Mon, 30 Jan 2017 21:59:25 +0000 Received: from magus.postgresql.org ([2a02:c0:301:0:ffff::29]) by malur.postgresql.org with esmtps (TLS1.2:ECDHE_RSA_AES_256_CBC_SHA384:256) (Exim 4.84_2) (envelope-from ) id 1cYJxW-0003u1-Hy for pgsql-hackers@postgresql.org; Mon, 30 Jan 2017 21:57:58 +0000 Received: from mail-wm0-x22a.google.com ([2a00:1450:400c:c09::22a]) by magus.postgresql.org with esmtps (TLS1.2:ECDHE_RSA_AES_256_CBC_SHA1:256) (Exim 4.84_2) (envelope-from ) id 1cYJxS-0002mi-TK for pgsql-hackers@postgresql.org; Mon, 30 Jan 2017 21:57:58 +0000 Received: by mail-wm0-x22a.google.com with SMTP id r141so53139269wmg.1 for ; Mon, 30 Jan 2017 13:57:54 -0800 (PST) DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=2ndquadrant-com.20150623.gappssmtp.com; s=20150623; h=subject:to:references:cc:from:message-id:date:user-agent :mime-version:in-reply-to:content-transfer-encoding; bh=NlTBy0LiMbBr5dmU8yk13pVErflNN6BZH4/UJLVwtWU=; b=uJsMBJpUBK0IKWcTQ/yzgfVVb+HoELekpQ4Vk6/vmSfDOSuPh5DtSJ8GMbnt9V9X/C c7/eFaXfXy/qZOFJIsTXAB2v/5jZ4jn4h6RRG48L23fNTqWhtifMGsBJadgQCP60n64u nIxTdpkEUqsMRMIf+Nkc7MjWVFg77LdBaJcrNe710lg1h1qAH978aoRYb2gCQBWBSbIC wGF2eaT6v6HBtck/uN3tO3puI05tp/ei0zrM+ntCaWacMQYOnEyB3Vbg+9P3BxKQzV3H 8qY4jP9dApHr42jjxo4Y/SBLv2f4hOer/XVsiu4fF621iet0mO39MUEgAQEu3S0SfLMy 8PgQ== X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20161025; h=x-gm-message-state:subject:to:references:cc:from:message-id:date :user-agent:mime-version:in-reply-to:content-transfer-encoding; bh=NlTBy0LiMbBr5dmU8yk13pVErflNN6BZH4/UJLVwtWU=; b=aqDQejHJWju8/qvJZHU5EzHIV2QevysMRGCbvYOnK2Cijkr35NK+2gXfBamn+BenGz ICuTcIaW9B6DrgUGh7p8eqGhUyNOl36OnloqZZo0+XchjVz91OeASD/1srjygVM45wZs b6TP71sElJ3rX6DRzvzFnhQCFSBX3Byme5IlUp5vAwfZm9Yr8NeA/+RN9xBwO+GZfzE7 ous3BogZFzSwpIcexF4JywACmb6lcEG+4/A3IetB1CSKcH87JCE7x0kXd0LsG5QRS7zC +AomxOZirGiBd5DyJ0c3cxY4FZdZZX9v3ax56W93Ol6CH/0zM5LCYhagzNx6Nq9FeQrz LQ5A== X-Gm-Message-State: AIkVDXIwetmUl59yvZRgGoXpeV3XJ5FEyscYeCV2h+JfgkqNIlmqpfkC+0/EormCK8jW8H1ZKvQZjIt812xYTtb+x0V82tDLJxpYb28ArzPCfDvlExGA5sf8iuA0tVlJhKSajzpFN6jSyB4wrInFTQPYgjR7dil5pXzZKE7a1yUMlaEV5dLLebFokST0GU7YaGwjSHiwCXkn X-Received: by 10.28.136.13 with SMTP id k13mr16486244wmd.94.1485813473107; Mon, 30 Jan 2017 13:57:53 -0800 (PST) Received: from [10.137.2.17] (ip-89-177-46-65.net.upcbroadband.cz. [89.177.46.65]) by smtp.gmail.com with ESMTPSA id w204sm20729338wmd.17.2017.01.30.13.57.51 (version=TLS1_2 cipher=ECDHE-RSA-AES128-GCM-SHA256 bits=128/128); Mon, 30 Jan 2017 13:57:52 -0800 (PST) Subject: Re: multivariate statistics (v19) To: Alvaro Herrera References: <20170130203714.latitwfmrzukgugh@alvherre.pgsql> Cc: Dilip Kumar , Amit Langote , Dean Rasheed , Heikki Linnakangas , Michael Paquier , Robert Haas , Tatsuo Ishii , David Steele , Tom Lane , Petr Jelinek , Jeff Janes , "pgsql-hackers@postgresql.org" From: Tomas Vondra Message-ID: Date: Mon, 30 Jan 2017 22:57:49 +0100 User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Thunderbird/45.4.0 MIME-Version: 1.0 In-Reply-To: <20170130203714.latitwfmrzukgugh@alvherre.pgsql> Content-Type: text/plain; charset=windows-1252; format=flowed Content-Transfer-Encoding: 7bit X-Pg-Spam-Score: -2.6 (--) List-Archive: List-Help: List-ID: List-Owner: List-Post: List-Subscribe: List-Unsubscribe: X-Mailing-List: pgsql-hackers Precedence: bulk Sender: pgsql-hackers-owner@postgresql.org On 01/30/2017 09:37 PM, Alvaro Herrera wrote: > Tomas Vondra wrote: > >> The 'built' flags may be easily replaced with a check if the bytea-like >> columns are NULL, and the 'enabled' columns may be replaced by the array of >> char, just like you proposed. >> >> That'd give us a single catalog looking like this: >> >> pg_mv_statistics >> starelid >> staname >> stanamespace >> staowner -- all the above as currently >> staenabled array of "char" {d,f,s} >> stakeys >> stadeps (dependencies) >> standist (ndistinct coefficients) >> stamcv (MCV list) >> stahist (histogram) >> >> Which is probably a better / simpler structure than the current one. > > Looks good to me. I don't think we need to keep the names very short -- > I would propose "standistinct", "stahistogram", "stadependencies". > Yeah, I got annoyed by the short names too. This however reminds me that perhaps pg_mv_statistic is not the best name. I know others proposed pg_statistic_ext (and pg_stats_ext), and while I wasn't a big fan initially, I think it's a better name. People generally don't know what 'multivariate' means, while 'extended' is better known (e.g. because Oracle uses it for similar stuff). So I think I'll switch to that name too. regards -- Tomas Vondra http://www.2ndQuadrant.com PostgreSQL Development, 24x7 Support, Remote DBA, Training & Services -- Sent via pgsql-hackers mailing list (pgsql-hackers@postgresql.org) To make changes to your subscription: http://www.postgresql.org/mailpref/pgsql-hackers