Subject: Re: rare crash - FailedAssertion snapbuild.c Line: 580

From: Pradeep Kumar <[email-masked]>
Date: Thu, 1 Aug 2024 15:29:20 +0530

Hello all,

Any update on this?

Thanks and regards
Pradeep

On Thu, Jul 25, 2024 at 1:09 PM Pradeep Kumar <[email-masked]>
wrote:

> Hello all,
>
> Message Id:
> https://www.postgresql.org/message-id/flat/3808dc548e144c860fc3fe57de013809%40xs4all.nl#72629a188e99e14387230fccc8eef518
>
> Actually I'm also facing this issue. Any solution regarding this? .Kindly
> give me the explanation of why this error occurs.
>
> Thanks and regards
> Pradeep
>

---

From: "Euler Taveira" <[email-masked]>
Date: Thu, 01 Aug 2024 15:09:15 -0300

> Any update on this?

Are you using version 11? This version is obsolete and is not supported
anymore. Consider a supported version [1].

Per the following commit (in version 16), this Assert was replaced by
elog.

commit: 240e0dbacd390a8465552e27c5af11f67d747adb
author: Amit Kapila <[email-masked]>
date: Mon, 21 Nov 2022 08:54:43 +0530
committer: Amit Kapila <[email-masked]>
date: Mon, 21 Nov 2022 08:54:43 +0530
Add additional checks while creating the initial decoding snapshot.

As per one of the CI reports, there is an assertion failure which
indicates that we were trying to use an unenforced xmin horizon for
decoding snapshots. Though, we couldn't figure out the reason for
assertion failure these checks would help us in finding the reason if the
problem happens again in the future.

Author: Amit Kapila based on suggestions by Andres Freund
Reviewd by: Andres Freund
Discussion: https://postgr.es/m/CAA4eK1L8wYcyTPxNzPGkhuO52WBGoOZbT0A73Le=[email-masked]

According to this discussion, there isn't a clue about the root cause.
If you have a test case, share it (mainly if you are observing it in
version 16+ that exposes some data which may be useful for analysis).

[1] https://www.postgresql.org/support/versioning/

--
Euler Taveira
EDB   https://www.enterprisedb.com/

---

From: Alexander Lakhin <[email-masked]>
Date: Fri, 2 Aug 2024 07:00:01 +0300

Hello Euler,

> version 16+ that exposes some data which may be useful for analysis).

Please take a look at [1], where I presented a reproducer for apparently
the same issue.

[1] https://www.postgresql.org/message-id/b91cf8ef-b5af-5def-ff05-bd67336ef907%40gmail.com

Best regards,
Alexander