Subject: Re: Use pg_icu_unicode_version(void) instead of pg_icu_unicode_version()

From: Joe Conway <[email-masked]>
Date: Fri, 27 Feb 2026 09:58:34 -0500

On 2/27/26 01:04, Chao Li wrote:
> What I'm interested in is the broader policy: when reviewing
> patches, if we encounter a foo() declaration, should we consistently
> request a change to foo(void)? If yes, the standard should be
> documented somewhere.

Perhaps here?

https://wiki.postgresql.org/wiki/Committing_checklist

-- 
Joe Conway
PostgreSQL Contributors Team
Amazon Web Services: https://aws.amazon.com

---

From: Andreas Karlsson <[email-masked]>
Date: Tue, 3 Mar 2026 02:22:21 +0100

> https://wiki.postgresql.org/wiki/Committing_checklist

Nah, I think we should just enable the warnings unless we have a good 
reason not to.

Andreas