Received: from malur.postgresql.org ([217.196.149.56]) by arkaria.postgresql.org with esmtps (TLS1.3) tls TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384 (Exim 4.94.2) (envelope-from ) id 1rSQRl-00Dgb7-1w for pgsql-hackers@arkaria.postgresql.org; Tue, 23 Jan 2024 23:44:49 +0000 Received: from localhost ([127.0.0.1] helo=malur.postgresql.org) by malur.postgresql.org with esmtp (Exim 4.94.2) (envelope-from ) id 1rSQRj-000Cpr-Ta for pgsql-hackers@arkaria.postgresql.org; Tue, 23 Jan 2024 23:44:47 +0000 Received: from magus.postgresql.org ([2a02:c0:301:0:ffff::29]) by malur.postgresql.org with esmtps (TLS1.3) tls TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384 (Exim 4.94.2) (envelope-from ) id 1rSQRj-000Coy-42 for pgsql-hackers@lists.postgresql.org; Tue, 23 Jan 2024 23:44:47 +0000 Received: from out5-smtp.messagingengine.com ([66.111.4.29]) by magus.postgresql.org with esmtps (TLS1.3) tls TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384 (Exim 4.94.2) (envelope-from ) id 1rSQRa-003NSE-59 for pgsql-hackers@lists.postgresql.org; Tue, 23 Jan 2024 23:44:45 +0000 Received: from compute2.internal (compute2.nyi.internal [10.202.2.46]) by mailout.nyi.internal (Postfix) with ESMTP id 569DD5C01B2; Tue, 23 Jan 2024 18:44:36 -0500 (EST) Received: from imap49 ([10.202.2.99]) by compute2.internal (MEProxy); Tue, 23 Jan 2024 18:44:36 -0500 DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=eulerto.com; h= cc:cc:content-type:content-type:date:date:from:from:in-reply-to :in-reply-to:message-id:mime-version:references:reply-to:subject :subject:to:to; s=fm1; t=1706053476; x=1706139876; bh=2I0l4TFHoR Mb9MImVaBgiAPENPs5aOqfq8HPcEkCybo=; b=CdX/OR74cxWvr10MvsZECkTOq4 Uo+clUbjzGvuqfNRNHo6dIAVzF/c/qRQ0FmLWQ8fLq3rS6dmfK1VECqGNk9ZeUVw n/VLuPTTdp9IemG4B+GWKfInRI4bn8atbVwk8gB1xhp0pVIT3ih+j1JCJefH8BQe /+zX/DYv9Nj2eAio206sMggd91vwKnCL5Lrk5h1zsB4Xkxr9tJWpwf5c29/pOFO5 kT7mEVigkFSs4Re/DUOEL33h2rnoxbUnLwPfpa4ZAw3iVB5VI5fqOb58gWb1QWCV UvBK6j5jCwFWUn7zoLafqiwgCJRVsEPd4puivlqBzfpfcu8tCRX2NN2KoGIw== DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d= messagingengine.com; h=cc:cc:content-type:content-type:date:date :feedback-id:feedback-id:from:from:in-reply-to:in-reply-to :message-id:mime-version:references:reply-to:subject:subject:to :to:x-me-proxy:x-me-proxy:x-me-sender:x-me-sender:x-sasl-enc; s= fm3; t=1706053476; x=1706139876; bh=2I0l4TFHoRMb9MImVaBgiAPENPs5 aOqfq8HPcEkCybo=; b=XLpuKd52pWr8FDdNwCV9reo3qiEjrBIyf80UD3FOaPhs nF40bLsflHl80WBKuPrXFVd4Mk8YZFktmuJFbj+qioENudnH2NuSwUa8D650X1GP QeAl7+D20cZ/F8pZA7mHNyIZgDyrXfQZZ5WTukh1tqR1Y2nOnVhtEzkenGzfyrCA +ZF7Ou2uYQMHKjACYG/l5NLnoGnYrm2JyMFlkz9EdJ5tdj60HwiLjIaCIa8DbfjZ kBENwP0WjdoIvw8p9fmZ+QUT/OnpPZ19ZOyqs94xVxnhxpbBwYpGjCspeKFX48Yw 41kXGlXDMeth7wZU7RJtOLrgZ5DCNqeA5RsjjWe8Fw== X-ME-Sender: X-ME-Proxy-Cause: gggruggvucftvghtrhhoucdtuddrgedvkedrvdekledgudefucetufdoteggodetrfdotf fvucfrrhhofhhilhgvmecuhfgrshhtofgrihhlpdfqfgfvpdfurfetoffkrfgpnffqhgen uceurghilhhouhhtmecufedttdenucesvcftvggtihhpihgvnhhtshculddquddttddmne cujfgurhepofgfggfkjghffffhvfevufgtsegrtderreerreejnecuhfhrohhmpedfgfhu lhgvrhcuvfgrvhgvihhrrgdfuceovghulhgvrhesvghulhgvrhhtohdrtghomheqnecugg ftrfgrthhtvghrnhepjeetgefhgeeifffgudeviefhleejheevkeelfeetteelueejgedt udevteekffejnecuffhomhgrihhnpehthhgvshgruhhruhhsrdgtohhmpdgvnhhtvghrph hrihhsvggusgdrtghomhenucevlhhushhtvghrufhiiigvpedtnecurfgrrhgrmhepmhgr ihhlfhhrohhmpegvuhhlvghrsegvuhhlvghrthhordgtohhm X-ME-Proxy: Feedback-ID: i0c21471d:Fastmail Received: by mailuser.nyi.internal (Postfix, from userid 501) id 9691515A0092; Tue, 23 Jan 2024 18:44:35 -0500 (EST) X-Mailer: MessagingEngine.com Webmail Interface User-Agent: Cyrus-JMAP/3.11.0-alpha0-119-ga8b98d1bd8-fm-20240108.001-ga8b98d1b MIME-Version: 1.0 Message-Id: In-Reply-To: References: <5ac50071-f2ed-4ace-a8fd-b892cffd33eb@www.fastmail.com> <2736443c-58e3-42df-8cc4-8c66106e3da5@app.fastmail.com> <78c88fa4-4960-4ce9-ae45-cda6302bd824@eisentraut.org> Date: Tue, 23 Jan 2024 20:44:15 -0300 From: "Euler Taveira" To: "Amit Kapila" , "kuroda.hayato@fujitsu.com" Cc: "Peter Eisentraut" , "pgsql-hackers@lists.postgresql.org" , "Shlok Kyal" , "vignesh C" , "Michael Paquier" , "Andres Freund" , "Ashutosh Bapat" Subject: Re: speed up a logical replica setup Content-Type: multipart/alternative; boundary=421b10bf8a2e453ea5734a44a0c82e9e List-Id: List-Help: List-Subscribe: List-Post: List-Owner: List-Archive: Archived-At: Precedence: bulk --421b10bf8a2e453ea5734a44a0c82e9e Content-Type: text/plain;charset=utf-8 Content-Transfer-Encoding: quoted-printable On Mon, Jan 22, 2024, at 6:22 AM, Amit Kapila wrote: > On Mon, Jan 22, 2024 at 2:38=E2=80=AFPM Hayato Kuroda (Fujitsu) > wrote: > > > > > > > Yet other options could be > > > > pg_buildsubscriber, pg_makesubscriber as 'build' or 'make' in th= e name > > > > sounds like we are doing some work to create the subscriber whic= h I > > > > think is the case here. > > > > > > I see your point here. pg_createsubscriber is not like createuser= in > > > that it just runs an SQL command. It does something different than > > > CREATE SUBSCRIBER. >=20 > Right. Subscriber has a different meaning of subscription. Subscription is an S= QL object. Subscriber is the server (node in replication terminology) where= the subscription resides. Having said that pg_createsubscriber doesn't seem = a bad name because you are creating a new subscriber. (Indeed, you are transfo= rming / converting but "create" seems closer and users can infer that it is a to= ol to build a new logical replica. > So a different verb would make that clearer. Maybe > > > something from here: https://www.thesaurus.com/browse/convert > > > > I read the link and found a good verb "switch". So, how about using = "pg_switchsubscriber"? > > >=20 > I also initially thought on these lines and came up with a name like > pg_convertsubscriber but didn't feel strongly about it as that would > have sounded meaningful if we use a name like > pg_convertstandbytosubscriber. Now, that has become too long. Having > said that, I am not opposed to it having a name on those lines. BTW, > another option that occurred to me today is pg_preparesubscriber. We > internally create slots and then wait for wal, etc. which makes me > sound like adding 'prepare' in the name can also explain the purpose. I think "convert" and "transform" fit for this case. However, "create", "convert" and "transform" have 6, 7 and 9 characters, respectively. I s= uggest that we avoid long names (subscriber already has 10 characters). My pref= erence is pg_createsubscriber. -- Euler Taveira EDB https://www.enterprisedb.com/ --421b10bf8a2e453ea5734a44a0c82e9e Content-Type: text/html;charset=utf-8 Content-Transfer-Encoding: quoted-printable
On Mon, Jan 22,= 2024, at 6:22 AM, Amit Kapila wrote:
On Mon, Jan 22, 2024 at 2:38=E2=80=AFPM Hayat= o Kuroda (Fujitsu)
> &g= t;
> > > Yet other options could be
> > > pg_buildsubscriber, pg_makesubscriber as 'build' or 'mak= e' in the name
> > > sounds like we are doing som= e work to create the subscriber which I
> > > thi= nk is the case here.
> >
> > I s= ee your point here.  pg_createsubscriber is not like createuser in<= br>
> > that it just runs an SQL command.  It does = something different than
> > CREATE SUBSCRIBER.
<= /div>

Right.

Subscriber has a different meaning of subscription. Subscription is an= SQL
object. Subscriber is the server (node in replication= terminology) where the
subscription resides. Having said = that pg_createsubscriber doesn't seem a bad
name because y= ou are creating a new subscriber. (Indeed, you are transforming /
converting but "create" seems closer and users can infer that it= is a tool to
build a new logical replica.
<= br>
  So a= different verb would make that clearer.  Maybe
> = > something from here: https://www.thesaurus.com/browse/convert
&= gt;
> I read the link and found a good verb "switch". S= o, how about using "pg_switchsubscriber"?
>

I also initially thought on these lines and came up wi= th a name like
pg_convertsubscriber but didn't feel strong= ly about it as that would
have sounded meaningful if we us= e a name like
pg_convertstandbytosubscriber. Now, that has= become too long. Having
said that, I am not opposed to it= having a name on those lines. BTW,
another option that oc= curred to me today is pg_preparesubscriber. We
internally = create slots and then wait for wal, etc. which makes me
so= und like adding 'prepare' in the name can also explain the purpose.
<= /div>

I think "convert" and "transform" = fit for this case. However, "create",
"convert" and "trans= form" have 6, 7 and 9 characters,  respectively. I suggest
that we avoid long names (subscriber already has 10 characters). M= y preference
is pg_createsubscriber.


--
Euler Taveira

--421b10bf8a2e453ea5734a44a0c82e9e--