public inbox for [email protected]  
help / color / mirror / Atom feed
From: Peter Eisentraut <[email protected]>
To: Andres Freund <[email protected]>
To: Amit Kapila <[email protected]>
Cc: Masahiko Sawada <[email protected]>
Cc: David G. Johnston <[email protected]>
Cc: pgsql-hackers <[email protected]>
Subject: Re: Design of pg_stat_subscription_workers vs pgstats
Date: Thu, 24 Feb 2022 10:20:39 +0100
Message-ID: <[email protected]> (raw)
In-Reply-To: <[email protected]>
References: <CAD21AoAqEt=TbUDY96Uhf9pNuh-NDR_3-CByd+xR=tFEq==1NA@mail.gmail.com>
	<CAD21AoA-MVZcMA1iYwbtvTCOHx1SwG8amQUTT8j2ssh2zuc6OQ@mail.gmail.com>
	<[email protected]>
	<CAD21AoDTO3bJvrc39Tv3VCeyUzZpimXnJuRhHQhKyjOWorHeOA@mail.gmail.com>
	<[email protected]>
	<CAD21AoA_r+Wc-zJZdy4Lii3oOvvdGcLwrY=2Y4y63HueYSd6Eg@mail.gmail.com>
	<[email protected]>
	<CAA4eK1+j00Pc+p=AfJLXh-a+OJ-a0UD4adMr2tRkQvKG_LggHA@mail.gmail.com>
	<[email protected]>
	<CAA4eK1J3dhfMRNQ6Q585nFr1vmXaTXVW9qv4hmUxLwDwJp-9RQ@mail.gmail.com>
	<[email protected]>

On 21.02.22 17:17, Andres Freund wrote:
> Hi,
> 
> On 2022-02-21 14:49:01 +0530, Amit Kapila wrote:
>> On Mon, Feb 21, 2022 at 1:18 PM Andres Freund <[email protected]> wrote:
>>>> * stats_reset (Time at which these statistics were last reset)
>>>>
>>>> The view name could be pg_stat_subscription_lrep,
>>>> pg_stat_logical_replication, or something on those lines.
>>>
>>> pg_stat_subscription_stats :)
> 
>> Having *stat* two times in the name sounds slightly odd to me but let
>> us see what others think. One more option could be
>> pg_stat_subscription_replication.
> 
> It was a joke, making light of our bad naming in pg_stat_*, not a serious
> suggestion...

I think pg_stat_subscription_stats is actually the least worst option.

Unless we want to consider renaming pg_stat_subscription (which is 
actually more like pg_stat_subscription_activity).  But I think that 
should be avoided.







view thread (40+ messages)  latest in thread

reply

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Reply to all the recipients using the --to and --cc options:
  reply via email

  To: [email protected]
  Cc: [email protected], [email protected], [email protected], [email protected], [email protected]
  Subject: Re: Design of pg_stat_subscription_workers vs pgstats
  In-Reply-To: <[email protected]>

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

This inbox is served by agora; see mirroring instructions
for how to clone and mirror all data and code used for this inbox