Subject: Re: SQL:2023 JSON simplified accessor support

From: Andrew Dunstan <[email-masked]>
Date: Fri, 27 Sep 2024 07:07:51 -0400

On 2024-09-27 Fr 5:49 AM, David E. Wheeler wrote:
> On Sep 26, 2024, at 16:45, Alexandra Wang <[email-masked]> wrote:
>
>> I didn’t run pgindent earlier, so here’s the updated version with the
>> correct indentation. Hope this helps!
> Oh,  nice! I don’t suppose the standard also has defined an operator equivalent to ->>, though, has it? I tend to want the text output far more often than a JSON scalar.
>

That would defeat being able to chain these.

cheers

andrew

--
Andrew Dunstan
EDB: https://www.enterprisedb.com

---

From: "David E. Wheeler" <[email-masked]>
Date: Fri, 27 Sep 2024 22:19:15 +0100

> That would defeat being able to chain these.

Not if it’s a different operator. But I’m fine to just keep using ->> at the end of a chain.

D