Received: from malur.postgresql.org ([217.196.149.56]) by arkaria.postgresql.org with esmtps (TLS1.3:ECDHE_RSA_AES_256_GCM_SHA384:256) (Exim 4.92) (envelope-from ) id 1kh8ns-0000df-VU for pgsql-hackers@arkaria.postgresql.org; Mon, 23 Nov 2020 10:10:36 +0000 Received: from localhost ([127.0.0.1] helo=malur.postgresql.org) by malur.postgresql.org with esmtp (Exim 4.92) (envelope-from ) id 1kh8nr-0008TH-V9 for pgsql-hackers@arkaria.postgresql.org; Mon, 23 Nov 2020 10:10:35 +0000 Received: from magus.postgresql.org ([2a02:c0:301:0:ffff::29]) by malur.postgresql.org with esmtps (TLS1.3:ECDHE_RSA_AES_256_GCM_SHA384:256) (Exim 4.92) (envelope-from ) id 1kh8nr-0008TA-O5 for pgsql-hackers@lists.postgresql.org; Mon, 23 Nov 2020 10:10:35 +0000 Received: from meesny.iki.fi ([195.140.195.201]) by magus.postgresql.org with esmtps (TLS1.3:ECDHE_RSA_AES_256_GCM_SHA384:256) (Exim 4.92) (envelope-from ) id 1kh8np-0005vF-FT for pgsql-hackers@postgresql.org; Mon, 23 Nov 2020 10:10:35 +0000 Received: from [192.168.1.113] (dsl-hkibng22-54faa4-119.dhcp.inet.fi [84.250.164.119]) (using TLSv1.3 with cipher TLS_AES_128_GCM_SHA256 (128/128 bits) key-exchange X25519 server-signature RSA-PSS (2048 bits) server-digest SHA256) (No client certificate requested) (Authenticated sender: hlinnaka) by meesny.iki.fi (Postfix) with ESMTPSA id F3C7420169; Mon, 23 Nov 2020 12:10:31 +0200 (EET) DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=iki.fi; s=meesny; t=1606126232; h=from:from:reply-to:subject:subject:date:date:message-id:message-id: to:to:cc:cc:mime-version:mime-version:content-type:content-type: content-transfer-encoding:content-transfer-encoding; bh=tl29pTqkC5LBmxTN73R7Ti/8iauGFfqd+5vQzrmKIHE=; b=q0mFLatm4A7QIgD3aQBSWilGIP3RXeivNi/nwcA9QmRIheHEoTiypJPJGNgMVTRe76r6Gm VDFsPOd9oz+t6AEDMIECjYJz9IJ7Sm3xJkoXexUYDEZLAdxhcEhUp/EgwkU3/IEmwygBWt XRVHC3yh8nfw87KnY32AdrFZymqxr5Y= From: Heikki Linnakangas Subject: prion failed with ERROR: missing chunk number 0 for toast value 14334 in pg_toast_2619 To: pgsql-hackers Cc: Justin Pryzby Message-ID: Date: Mon, 23 Nov 2020 12:10:31 +0200 User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:78.0) Gecko/20100101 Thunderbird/78.4.0 MIME-Version: 1.0 Content-Type: text/plain; charset=utf-8; format=flowed Content-Language: en-US Content-Transfer-Encoding: 7bit ARC-Message-Signature: i=1; a=rsa-sha256; c=relaxed/relaxed; d=iki.fi; s=meesny; t=1606126232; h=from:from:reply-to:subject:subject:date:date:message-id:message-id: to:to:cc:cc:mime-version:mime-version:content-type:content-type: content-transfer-encoding:content-transfer-encoding; bh=tl29pTqkC5LBmxTN73R7Ti/8iauGFfqd+5vQzrmKIHE=; b=cL0qK/SDmCKq6xZxRncLI/ow6oul/XRVlAgS5RFSKGR6LsokXs3RQxWS63PnutKrqyrPf4 osFRjbLNcTXsWAdIB0Nvjep/73xulG5ZFCvKfsR7krnoUVrubl+/cKNLPJBi9+mEkcQESz 6xeKBH2WJJPws4i35nxmcSI4Wt5jrAg= ARC-Authentication-Results: i=1; ORIGINATING; auth=pass smtp.auth=hlinnaka smtp.mailfrom=hlinnaka@iki.fi ARC-Seal: i=1; s=meesny; d=iki.fi; t=1606126232; a=rsa-sha256; cv=none; b=lSdPX9j13ksq5ZwGweMb5WOJBqgvst0tsYOp9EnFiTEmjakkvwDhICvim9xXFxU9kEEDAq 4pjLvGzJXmT2aN3YrVC3GVt8fOjart7g+kMem8pL82AKwy94TqnK+mNm+aMibHoIeELFwy Kq4l8aq/uXy0kWBtysFEXF6SuSDm6OA= List-Id: List-Help: List-Subscribe: List-Post: List-Owner: List-Archive: Precedence: bulk Hi, After my commit c532d15ddd to split up copy.c, buildfarm animal "prion" failed in pg_upgrade (https://buildfarm.postgresql.org/cgi-bin/show_log.pl?nm=prion&dt=2020-11-23%2009%3A23%3A16): > Upgrade Complete > ---------------- > Optimizer statistics are not transferred by pg_upgrade so, > once you start the new server, consider running: > /home/ec2-user/bf/root/HEAD/pgsql.build/tmp_install/home/ec2-user/bf/root/HEAD/inst/bin/vacuumdb --all --analyze-in-stages > > Running this script will delete the old cluster's data files: > ./delete_old_cluster.sh > waiting for server to start.... done > server started > pg_dump: error: query failed: ERROR: missing chunk number 0 for toast value 14334 in pg_toast_2619 > pg_dump: error: query was: SELECT > a.attnum, > a.attname, > a.atttypmod, > a.attstattarget, > a.attstorage, > t.typstorage, > a.attnotnull, > a.atthasdef, > a.attisdropped, > a.attlen, > a.attalign, > a.attislocal, > pg_catalog.format_type(t.oid, a.atttypmod) AS atttypname, > array_to_string(a.attoptions, ', ') AS attoptions, > CASE WHEN a.attcollation <> t.typcollation THEN a.attcollation ELSE 0 END AS attcollation, > pg_catalog.array_to_string(ARRAY(SELECT pg_catalog.quote_ident(option_name) || ' ' || pg_catalog.quote_literal(option_value) FROM pg_catalog.pg_options_to_table(attfdwoptions) ORDER BY option_name), E', > ') AS attfdwoptions, > a.attidentity, > CASE WHEN a.atthasmissing AND NOT a.attisdropped THEN a.attmissingval ELSE null END AS attmissingval, > a.attgenerated > FROM pg_catalog.pg_attribute a LEFT JOIN pg_catalog.pg_type t ON a.atttypid = t.oid > WHERE a.attrelid = '35221'::pg_catalog.oid AND a.attnum > 0::pg_catalog.int2 > ORDER BY a.attnum > pg_dumpall: error: pg_dump failed on database "regression", exiting > waiting for server to shut down.... done > server stopped > pg_dumpall of post-upgrade database cluster failed > make: *** [check] Error 1 I don't think this is related to commit c532d15ddd, as there is no COPY involved here. I have no clue what might might be going on here, though. Any ideas? Googling around, I found one report that looks somewhat similar: https://www.postgresql.org/message-id/20190830142655.GA14011%40telsasoft.com. That was with CLUSTER/VACUUM FULL, while pg_upgrade performs ANALYZE. - Heikki