Subject: Windows meson build

From: "Kohei Harikae (Fujitsu)" <[email-masked]>
Date: Tue, 5 Nov 2024 06:32:51 +0000

Hi,

I do not use pkgconf in my Windows environment.
In my Windows environment, I could not build the following OSS with meson.
- 0001 icu
- 0002 libxml
- 0003 libxslt
- 0004 lz4
- 0005 tcl
- 0006 zlib
- 0007 zstd

[1]thread, I created a patch like the one in the attached file, and now I can build.
Would you like to be able to build OSS with Windows meson without using pkgconf?

 [1] https://www.postgresql.org/message-id/flat/CA%2BOCxowQhMHFNRLTsXNuJpC96KRtSPHYKJuOS%3Db-Zrwmy-P4-g%40mail.gmail.com

Regards,
Kohei Harikae

---

From: Andres Freund <[email-masked]>
Date: Wed, 6 Nov 2024 14:04:57 -0500

Hi,

> Would you like to be able to build OSS with Windows meson without using pkgconf?

You can use pkgconf or cmake for the dependencies.  I don't want to add "raw"
dependency handling for every dependency, they each build in too many variants
for that to be a sensible investment of time.

Greetings,

Andres Freund