Subject: Lack of new line between IF statements

From: Fabrízio de Royes Mello <[email-masked]>
Date: Sat, 23 Mar 2019 08:54:26 -0300

Hi all,

The attached patch just a very minor adjustment to
src/bin/pg_checksums/pg_checksums.c to add new line between some IF
statements.

Regards,

-- 
   Fabrízio de Royes Mello         Timbira - http://www.timbira.com.br/
   PostgreSQL: Consultoria, Desenvolvimento, Suporte 24x7 e Treinamento
diff --git a/src/bin/pg_checksums/pg_checksums.c b/src/bin/pg_checksums/pg_checksums.c
index f9ab27c..61bfa45 100644
--- a/src/bin/pg_checksums/pg_checksums.c
+++ b/src/bin/pg_checksums/pg_checksums.c
@@ -435,12 +435,14 @@ main(int argc, char *argv[])
 		fprintf(stderr, _("%s: data checksums are not enabled in cluster\n"), progname);
 		exit(1);
 	}
+
 	if (ControlFile->data_checksum_version == 0 &&
 		mode == PG_MODE_DISABLE)
 	{
 		fprintf(stderr, _("%s: data checksums are already disabled in cluster.\n"), progname);
 		exit(1);
 	}
+
 	if (ControlFile->data_checksum_version > 0 &&
 		mode == PG_MODE_ENABLE)
 	{

---

From: Michael Paquier <[email-masked]>
Date: Sat, 23 Mar 2019 22:02:42 +0900

> src/bin/pg_checksums/pg_checksums.c to add new line between some IF

Thanks.  This makes the code more consistent with the surroundings, so
done.  At the same time I have improved the error messages in the
area as they should not have a period.
--
Michael