Subject: Re: Lack of possibility to specify CTAS TAM

From: "David G. Johnston" <[email-masked]>
Date: Wed, 31 Jul 2024 00:22:00 -0700

On Wednesday, July 31, 2024, Kirill Reshke <[email-masked]> wrote:
>
>
> The same storage specification feature can actually be supported for
> CTAE (like CTAS but execute) and CREATE MATERIALIZED VIEW.
>
>
On a related note, the description here seems outdated.

https://www.postgresql.org/docs/current/runtime-config-client.html#GUC-DEFAULT-TABLE-ACCESS-METHOD

CMV also has this syntax already; we don’t actually have CTAE presently,
correct?

David J.

---

From: "David G. Johnston" <[email-masked]>
Date: Wed, 31 Jul 2024 00:27:15 -0700

On Wednesday, July 31, 2024, David G. Johnston <[email-masked]>
wrote:

>  https://www.postgresql.org/docs/current/runtime-config-
> client.html#GUC-DEFAULT-TABLE-ACCESS-METHOD
>

Nevermind, re-reading it I see it is correct.  The others are all covered
by “create” while “select into” is called out because of its reliance on
the default.

David J.