Subject: Re: [PATCH] Extend the length of BackgroundWorker.bgw_library_name

From: Nathan Bossart <[email-masked]>
Date: Mon, 3 Jul 2023 15:08:42 -0700

On Sun, Jul 02, 2023 at 04:37:52PM -0700, Yurii Rashkovskii wrote:
> Thank you for revising the patch. While this is relatively minor, I think
> it should be set to MAXPGPATH directly to clarify their relationship.

Committed.  I set the size to MAXPGPATH directly instead of inventing a new
macro with the same value.

-- 
Nathan Bossart
Amazon Web Services: https://aws.amazon.com

---

From: Yurii Rashkovskii <[email-masked]>
Date: Mon, 3 Jul 2023 18:00:12 -0700

Nathan,

> macro with the same value.

Great, thank you! The reason I was leaving the other constant in place to
make upgrading extensions trivial (so that they don't need to adjust for
this), but if you think this is a better way, I am fine with it.

-- 
Y.

---

From: Nathan Bossart <[email-masked]>
Date: Mon, 3 Jul 2023 20:12:26 -0700

> this), but if you think this is a better way, I am fine with it.

Sorry, I'm not following.  Which constant are you referring to?

---

From: Yurii Rashkovskii <[email-masked]>
Date: Tue, 4 Jul 2023 07:40:14 -0700

Nathan,

> Sorry, I'm not following.  Which constant are you referring to?

Apologies, I misread the final patch. All good!

-- 
Y.