Subject: Re: Correct SQLSTATE for ENOMEM in file access

From: Alexander Kuzmenkov <[email-masked]>
Date: Fri, 2 Feb 2024 20:28:39 +0100

On Fri, Feb 2, 2024 at 8:12 PM Tom Lane <[email-masked]> wrote:
> Hmm, do you think this is actually reachable?  AFAIK we should only be
> calling errcode_for_file_access() after functions that are unlikely to
> report ENOMEM.

It's reachable, that's how I noticed. I'm seeing logs like "XX000:
could not load library \"/usr/lib/postgresql/15/lib/plpgsql.so\": out
of memory" from internal_load_library and so on. Not sure what is the
exact configuration required to reproduce this, probably at least the
overcommit should be disabled.

---

From: Tom Lane <[email-masked]>
Date: Fri, 02 Feb 2024 15:20:13 -0500

> overcommit should be disabled.

OK, can't argue with experimental evidence ;-)

			regards, tom lane