Subject: Re: pg_logical_emit_message() misses a XLogFlush()

From: Amit Kapila <[email-masked]>
Date: Tue, 17 Oct 2023 11:57:33 +0530

On Mon, Oct 16, 2023 at 12:47 PM Michael Paquier <[email-masked]> wrote:
>
> On Fri, Oct 13, 2023 at 03:20:30PM +0530, Amit Kapila wrote:
> > I would prefer to associate the new parameter 'flush' with
> > non-transactional messages as per the proposed patch.
>
> Check.
>
> > Is there a reason to make the functions strict now when they were not earlier?
>
> These two are already STRICT on HEAD:
> =# select proname, provolatile, proisstrict from pg_proc
>      where proname ~ 'message';
>          proname         | provolatile | proisstrict
> -------------------------+-------------+-------------
>  pg_logical_emit_message | v           | t
>  pg_logical_emit_message | v           | t
> (2 rows)
>

oh, I misunderstood the default.

>
> An updated version is attached.  How does it look?
>

LGTM.

-- 
With Regards,
Amit Kapila.

---

From: Michael Paquier <[email-masked]>
Date: Wed, 18 Oct 2023 12:50:35 +0900

> LGTM.

Thanks, I've applied that, then.
--
Michael