Subject: Re: Remove unused argument from ApplyLogicalMappingFile()

From: Fujii Masao <[email-masked]>
Date: Wed, 28 Jan 2026 18:23:47 +0900

On Wed, Jan 28, 2026 at 2:18 PM Hayato Kuroda (Fujitsu)
<[email-masked]> wrote:
>
> Dear Nagata-san,
>
> > I noticed that ApplyLogicalMappingFile() has an unused argument.
> > If there is no specific reason for keeping it, I think it could be
> > removed. I have attached a small patch that removes this argument.

Thanks for the patch! I will commit it.

> Good catch. I found that ApplyLogicalMappingFile() has the argument since it was
> introduced (b89e151) and was not used from the beginning.

Yes.

> I removed the argument and ran tests for subscription, they could be passed.

Thanks for the test!

Regards,

-- 
Fujii Masao

---

From: Fujii Masao <[email-masked]>
Date: Fri, 30 Jan 2026 09:07:04 +0900

> Thanks for the patch! I will commit it.

I've pushed the patch. Thanks!

Regards,

-- 
Fujii Masao