Subject: Re: PG 16 draft release notes ready

From: jian he <[email-masked]>
Date: Fri, 19 May 2023 10:41:59 +0800

On Fri, May 19, 2023 at 4:49 AM Bruce Momjian <[email-masked]> wrote:

> I have completed the first draft of the PG 16 release notes.  You can
> see the output here:
>
>         https://momjian.us/pgsql_docs/release-16.html
>
> I will adjust it to the feedback I receive;  that URL will quickly show
> all updates.
>
> I learned a few things creating it this time:
>
> *  I can get confused over C function names and SQL function names in
>    commit messages.
>
> *  The sections and ordering of the entries can greatly clarify the
>    items.
>
> *  The feature count is slightly higher than recent releases:
>
>         release-10:  189
>         release-11:  170
>         release-12:  180
>         release-13:  178
>         release-14:  220
>         release-15:  184
> -->     release-16:  200
>
> --
>   Bruce Momjian  <[email-masked]>        https://momjian.us
>   EDB                                      https://enterprisedb.com
>
>   Only you can decide what is important to you.

* When granting role membership, require the granted-by role to be a role
> that has appropriate permissions (Robert Haas)
> This is a requirement even when the superuser is granting role membership.

an exception would be the granted-by is the bootstrap superuser.

---

From: Bruce Momjian <[email-masked]>
Date: Thu, 18 May 2023 23:15:09 -0400

> an exception would be the granted-by is the bootstrap superuser.

Okay, updated text is:

	<listitem>
	<para>
	When granting role membership, require the granted-by role to be a role that has appropriate permissions (Robert Haas)
	</para>
	
	<para>
	This is a requirement even when a non-bootstrap superuser is granting role membership.
	</para>
	</listitem>