Subject: Re: Fix port/pg_iovec.h building extensions on x86_64-darwin

From: Nathan Bossart <[email-masked]>
Date: Fri, 8 Nov 2024 14:00:36 -0600

On Fri, Nov 08, 2024 at 08:08:06PM +0100, Wolfgang Walther wrote:
> @@ -68,7 +68,7 @@ pg_preadv(int fd, const struct iovec *iov, int iovcnt, off_t offset)
>  		}
>  		sum += part;
>  		offset += part;
> -		if (part < iov[i].iov_len)
> +		if ((size_t) part < iov[i].iov_len)
>  			return sum;
>  	}
>  	return sum;
> @@ -107,7 +107,7 @@ pg_pwritev(int fd, const struct iovec *iov, int iovcnt, off_t offset)
>  		}
>  		sum += part;
>  		offset += part;
> -		if (part < iov[i].iov_len)
> +		if ((size_t) part < iov[i].iov_len)
>  			return sum;
>  	}
>  	return sum;

This looks correct to me.  At this point in the code, we know that part >=
0, so casting it to an unsigned long ought to be okay.

-- 
nathan

---

From: Nathan Bossart <[email-masked]>
Date: Fri, 8 Nov 2024 15:20:00 -0600

Here is a new version of the patch with an updated commit message.  The
cfbot results [0] look good, so I plan to commit this one shortly unless
someone objects.

[0] https://cirrus-ci.com/build/6599760059039744

-- 
nathan
>From 5e7156defd3a169323e2bc354c3a3c4cb232fa67 Mon Sep 17 00:00:00 2001
From: Nathan Bossart <[email-masked]>
Date: Fri, 8 Nov 2024 15:16:41 -0600
Subject: [PATCH v2 1/1] Fix sign-compare warnings in pg_iovec.h.

The code in question (pg_preadv() and pg_pwritev()) has been around
for a while, but commit 15c9ac3629 moved it to a header file.  If
third-party code that includes this header file is built with
-Wsign-compare on a system without preadv() or pwritev(), warnings
ensue.  This commit fixes said warnings by casting the result of
pg_pread()/pg_pwrite() to size_t, which should be safe because we
have already checked for a negative value.

Author: Wolfgang Walther
Discussion: https://postgr.es/m/16989737-1aa8-48fd-8dfe-b7ada06509ab%40technowledgy.de
Backpatch-through: 17
---
 src/include/port/pg_iovec.h | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/src/include/port/pg_iovec.h b/src/include/port/pg_iovec.h
index 7255c1bd91..e5fe677b37 100644
--- a/src/include/port/pg_iovec.h
+++ b/src/include/port/pg_iovec.h
@@ -68,7 +68,7 @@ pg_preadv(int fd, const struct iovec *iov, int iovcnt, off_t offset)
 		}
 		sum += part;
 		offset += part;
-		if (part < iov[i].iov_len)
+		if ((size_t) part < iov[i].iov_len)
 			return sum;
 	}
 	return sum;
@@ -107,7 +107,7 @@ pg_pwritev(int fd, const struct iovec *iov, int iovcnt, off_t offset)
 		}
 		sum += part;
 		offset += part;
-		if (part < iov[i].iov_len)
+		if ((size_t) part < iov[i].iov_len)
 			return sum;
 	}
 	return sum;
-- 
2.39.5 (Apple Git-154)

---

From: Nathan Bossart <[email-masked]>
Date: Fri, 8 Nov 2024 16:15:47 -0600

> cfbot results [0] look good, so I plan to commit this one shortly unless

Committed.

-- 
nathan