Subject: [PATCH] Remove workarounds to format [u]int64's

From: Aleksander Alekseev <[email-masked]>
Date: Mon, 21 Mar 2022 11:52:14 +0300

Hi hackers,

I learned from Tom [1] that we can simplify the code like:

```
char buff[32];
snprintf(buf, sizeof(buf), INT64_FORMAT, ...)
ereport(WARNING, (errmsg("%s ...", buf)));
```

... and rely on %lld/%llu now as long as we explicitly cast the
argument to long long int / unsigned long long. This was previously
addressed in 6a1cd8b9 and d914eb34, but I see more places where we
still use an old approach.

Suggested patch fixes this. Tested locally - no warnings; passes all the tests.

[1] https://www.postgresql.org/message-id/771048.1647528068%40sss.pgh.pa.us

-- 
Best regards,
Aleksander Alekseev

---

From: Pavel Borisov <[email-masked]>
Date: Mon, 21 Mar 2022 13:12:33 +0400

пн, 21 мар. 2022 г. в 12:52, Aleksander Alekseev <[email-masked]>:

> [1]
> https://www.postgresql.org/message-id/771048.1647528068%40sss.pgh.pa.us
>
> Hi, Alexander!
Probably you can do (long long) instead of (long long int). It is shorter
and this is used elsewhere in the code.

-- 
Best regards,
Pavel Borisov

Postgres Professional: http://postgrespro.com <http://www.postgrespro.com>