Subject: RE: Handle infinite recursion in logical replication setup

From: "[email-masked]" <[email-masked]>
Date: Mon, 7 Mar 2022 06:12:50 +0000

Dear Peter,

> > So, why does the patch use syntax option 1?

IMU it might be useful for the following case.

Assuming that multi-master configuration with node1, node2.
Node1 has a publication pub1 and a subscription sub2, node2 has pub2 and sub1.

From that situation, please consider that new node node3 is added
that subscribe some changes from node2.

If the feature is introduced as option1, new publication must be defined in node2.
If that is introduced as option2, however, maybe pub2 can be reused.
i.e. multiple declaration of publications can be avoided.

Best Regards,
Hayato Kuroda
FUJITSU LIMITED

---

From: Peter Smith <[email-masked]>
Date: Mon, 7 Mar 2022 17:20:03 +1100

> i.e. multiple declaration of publications can be avoided.

Yes. Thanks for the example. I had the same observation in my last post  [1]

------
[1] https://www.postgresql.org/message-id/CAHut%2BPtRxiQR_4UFLNThg-NNRV447FvwtcR-BvqMzjyMJXKwfw%40mail.gmail.com

Kind Regards,
Peter Smith
Fujitsu Australia.