Subject: Re: Inconsistent terminology for -j/--jobs option in documentation

From: Tatsuro Yamada <[email-masked]>
Date: Sun, 11 Jan 2026 13:01:33 +0900

Hi Michael-san,

On Sat, Jan 10, 2026 at 1:03 PM Michael Paquier <[email-masked]> wrote:

> On Sat, Jan 10, 2026 at 11:48:21AM +0900, Tatsuro Yamada wrote:
> > To double-check, I also looked at the documentation for vacuumdb,
> > reindexdb, and pg_upgrade, and all of them use "njobs".
>
> As far as I can see:
> $ cd doc && git grep "number-of-jobs" | wc -l
> 3
> $ cd doc && git grep "njobs" | wc -l
> 14
>
> While it is minor, I agree that we could just make things consistent
> across the board as you are suggesting, so LGTM.

Thanks!
Yeah, it's minor but there is a quote that says God is in the details.

Regards,
Tatsuro Yamada

---

From: Michael Paquier <[email-masked]>
Date: Sun, 11 Jan 2026 15:27:18 +0900

> Yeah, it's minor but there is a quote that says God is in the details.

At some degree, yes, see 540c39cc56f5.
--
Michael

---

From: Tatsuro Yamada <[email-masked]>
Date: Mon, 12 Jan 2026 10:41:42 +0900

Hi Michael-san,

> At some degree, yes, see 540c39cc56f5.

Thank you for committing the patch!

Regards,
Tatsuro Yamada