Subject: Re: doc: add missing "id" attributes to extension packaging page

From: vignesh C <[email-masked]>
Date: Mon, 9 Jan 2023 08:08:22 +0530

On Mon, 9 Jan 2023 at 08:01, vignesh C <[email-masked]> wrote:
>
> On Wed, 4 Jan 2023 at 04:13, Karl O. Pinc <[email-masked]> wrote:
> >
> > On Tue, 3 Jan 2023 21:35:09 +0100
> > Brar Piening <[email-masked]> wrote:
> >
> > > On 02.01.2023 at 21:53, Karl O. Pinc wrote:
> > > > If the author will look over my version of the patch I believe it
> > > > can be approved and sent on to the committers.
> > >
> > > LGTM.
> >
> > Approved for committer!
>
> The patch does not apply on top of HEAD as in [1], please post a rebased patch:
> === Applying patches on top of PostgreSQL commit ID
> cd9479af2af25d7fa9bfd24dd4dcf976b360f077 ===
> === applying patch ./add_html_ids_v2.patch
> ....
> patching file doc/src/sgml/ref/pgbench.sgml
> patching file doc/src/sgml/ref/psql-ref.sgml
> Hunk #73 FAILED at 1824.
> ....
> 2 out of 208 hunks FAILED -- saving rejects to file
> doc/src/sgml/ref/psql-ref.sgml.rej
>
> [1] - http://cfbot.cputube.org/patch_41_4041.log

There are couple of commitfest entries for this:
https://commitfest.postgresql.org/41/4041/
https://commitfest.postgresql.org/41/4042/

Can one of them be closed?

Regards,
Vignesh

---

From: Brar Piening <[email-masked]>
Date: Mon, 9 Jan 2023 08:31:22 +0100

On 09.01.2023 at 03:38, vignesh C wrote:
> https://commitfest.postgresql.org/41/4042/ Can one of them be closed?
I've split the initial patch into two parts upon Álvaro's request in [1]
so that we can discuss them separately

https://commitfest.postgresql.org/41/4041/ is tracking the patch you've
been trying to apply and that I've just sent a rebased version for. It
only adds (invisible) ids to the HTML documentation and can be closed
once you've applied the patch.
https://commitfest.postgresql.org/41/4042/ is tracking a different patch
that makes the ids and the corresponding links discoverable at the HTML
surface. Hover one of the psql options in [2] to see the behavior. This
one still needs reviewing and there is no discussion around it yet.

Regards,
Brar

[1]
https://www.postgresql.org/message-id/20221206083809.3kaygnh2xswoxslj%40alvherre.pgsql
[2] https://pgdocs.piening.info/app-psql.html#APP-PSQL-OPTION-PORT