Subject: CFbot does not recognize patch contents

From: Tatsuo Ishii <[email-masked]>
Date: Sun, 12 May 2024 15:50:06 +0900 (JST)

After sending out my v18 patches:
https://www.postgresql.org/message-id/20240511.162307.2246647987352188848.t-ishii%40sranhm.sra.co.jp

CFbot complains that the patch was broken:
http://cfbot.cputube.org/patch_48_4460.log

=== Applying patches on top of PostgreSQL commit ID 31e8f4e619d9b5856fa2bd5713cb1e2e170a9c7d ===
=== applying patch ./v18-0001-Row-pattern-recognition-patch-for-raw-parser.patch
gpatch: **** Only garbage was found in the patch input.

The patch was generated by git-format-patch (same as previous
patches).  I failed to find any patch format problem in the
patch. Does anybody know what's wrong here?

Best reagards,
--
Tatsuo Ishii
SRA OSS LLC
English: http://www.sraoss.co.jp/index_en/
Japanese:http://www.sraoss.co.jp

---

From: Nazir Bilal Yavuz <[email-masked]>
Date: Sun, 12 May 2024 12:08:47 +0300

Hi,

> patch. Does anybody know what's wrong here?

I am able to apply all your patches. I found that a similar thing
happened before [0] and I guess your case is similar. Adding Thomas to
CC, he may be able to help more.

Nitpick: There is a trailing space warning while applying one of your patches:
Applying: Row pattern recognition patch (docs).
.git/rebase-apply/patch:81: trailing whitespace.
 company  |   tdate    | price | first_value | max | count

[0] postgr.es/m/CA%2BhUKGLiY1e%2B1%3DpB7hXJOyGj1dJOfgde%2BHmiSnv3gDKayUFJMA%40mail.gmail.com

-- 
Regards,
Nazir Bilal Yavuz
Microsoft

---

From: Tatsuo Ishii <[email-masked]>
Date: Sun, 12 May 2024 19:11:11 +0900 (JST)

> CC, he may be able to help more.

Ok. Thanks for the info.

>  company  |   tdate    | price | first_value | max | count

Yes, I know. The reason why there's a trailing whitespace is, I copied
the psql output and pasted it into the docs. I wonder why psql adds
the whitespace. Unless there's a good reason to do that, I think it's
better to fix psql so that it does not emit trailing spaces in its
output.

Best reagards,

---

From: Thomas Munro <[email-masked]>
Date: Wed, 15 May 2024 14:54:39 +1200

> > CC, he may be able to help more.

This obviously fixed itself automatically soon after this message, but
I figured out what happened:  I had not actually fixed that referenced
bug in cfbot :-(.  It was checking for HTTP error codes correctly in
the place that reads emails from the archives, but not the place that
downloads patches, so in this case I think when it tried to follow the
link[1] to download the patch, I guess it must have pulled down a
transient Varnish error message (I don't know what, I don't store it
anywhere), and tried to apply that as a patch.  Oops.  Fixed[2].

[1] https://www.postgresql.org/message-id/attachment/160138/v18-0001-Row-pattern-recognition-patch-for-raw-parser.patch
[2] https://github.com/macdice/cfbot/commit/ec33a65a877a88befc29ea220e87b98c89b27dcc