Subject: Re: A qsort template

From: Justin Pryzby <[email-masked]>
Date: Thu, 19 May 2022 15:12:54 -0500

On Fri, Apr 22, 2022 at 11:37:29AM +0700, John Naylor wrote:
> On Fri, Apr 22, 2022 at 11:13 AM David Rowley <[email-masked]> wrote:
> >
> > On Thu, 21 Apr 2022 at 19:09, John Naylor <[email-masked]> wrote:
> > > I intend to commit David's v2 fix next week, unless there are
> > > objections, or unless he beats me to it.
> >
> > I wasn't sure if you wanted to handle it or not, but I don't mind
> > doing it, so I just pushed it after a small adjustment to a comment.
> 
> Thank you!

Should these debug lines be removed ?

elog(DEBUG1, "qsort_tuple");

Perhaps if I ask for debug output, I shouldn't be surprised if it changes
between major releases - but I still found this surprising.

I'm sure it's useful during development and maybe during beta.  It could even
make sense if it were shown during regression tests (preferably at DEBUG2).
But right now it's not.  is that

ts=# \dt
DEBUG:  qsort_tuple
List of relations

-- 
Justin

---

From: Peter Geoghegan <[email-masked]>
Date: Thu, 19 May 2022 15:24:05 -0700

> elog(DEBUG1, "qsort_tuple");

I agree -- DEBUG1 seems too chatty for something like this. DEBUG2
would be more appropriate IMV. Though I don't feel very strongly about
it.

--
Peter Geoghegan

---

From: Tom Lane <[email-masked]>
Date: Thu, 19 May 2022 18:43:41 -0400

> would be more appropriate IMV. Though I don't feel very strongly about

Given the lack of context identification, I'd put the usefulness of
these in production at close to zero.  +1 for removing them
altogether, or failing that, downgrade to DEBUG5 or so.

			regards, tom lane

---

From: John Naylor <[email-masked]>
Date: Fri, 20 May 2022 13:40:25 +0700

> altogether, or failing that, downgrade to DEBUG5 or so.

I agree this is only useful in development. Removal sounds fine to me,
so I'll do that soon.

-- 
John Naylor
EDB: http://www.enterprisedb.com

---

From: John Naylor <[email-masked]>
Date: Mon, 23 May 2022 13:17:05 +0700

> I agree this is only useful in development. Removal sounds fine to me,

This is done.