Subject: Re: Can we remove support for standard_conforming_strings = off yet?

From: Julien Rouhaud <[email-masked]>
Date: Wed, 21 Jan 2026 18:32:11 +0800

Hi,

On Tue, Jan 20, 2026 at 01:31:53PM -0500, Tom Lane wrote:
> So, nobody's actually spoken against this change.  I think we should
> go forward with it, for the reasons I gave at the top of the thread
> and because "if not now, when?".  I have little doubt that if there
> is anyone still running with standard_conforming_strings = off, they
> aren't going to change until forced to.  So unless we want to live
> with the potential security hazard forever, we're going to have to
> make a breaking change sometime.

+1 from me.  All of that is sensible, plus from an extension point of view it's
easy to write code that is broken with standard_conforming_strings = off so
it's one less thing to worry about.

---

From: Tom Lane <[email-masked]>
Date: Wed, 21 Jan 2026 15:09:30 -0500

> it's one less thing to worry about.

Pushed.

			regards, tom lane

---

From: Bruce Momjian <[email-masked]>
Date: Wed, 21 Jan 2026 15:25:16 -0500

> > it's one less thing to worry about.

Great, thanks.

-- 
  Bruce Momjian  <[email-masked]>        https://momjian.us
  EDB                                      https://enterprisedb.com

  Do not let urgent matters crowd out time for investment in the future.

---

From: jian he <[email-masked]>
Date: Fri, 30 Jan 2026 18:10:47 +0800

hi.

_allocAH is called by OpenArchive and CreateArchive. in  _allocAH, we can set

AH->public.std_strings = true;

that would be more future-proof, otherwise after OpenArchive,
executing the query ``SET standard_conforming_strings = off;``
would result in an error.

--
jian
https://www.enterprisedb.com/