Subject: Re: automating RangeTblEntry node support

From: Paul Jungwirth <[email-masked]>
Date: Fri, 16 Feb 2024 12:36:24 -0800

On 1/15/24 02:37, Peter Eisentraut wrote:
> In this updated patch set, I have also added the treatment of the Constraint type.  (I also noted 
> that the manual read/write functions for the Constraint type are out-of-sync again, so simplifying 
> this would be really helpful.)  I have also added commit messages to each patch.
> 
> The way I have re-ordered the patch series now, I think patches 0001 through 0003 are candidates for 
> inclusion after review, patch 0004 still needs a bit more analysis and testing, as described therein.

I had to apply the first patch by hand (on 9f13376396), so this looks due for a rebase. Patches 2-4 
applied fine.

Compiles & passes tests after each patch.

The overall idea seems like a good improvement to me.

A few remarks about cleaning up the RangeTblEntry comments:

After the fourth patch we have a "Fields valid in all RTEs" comment twice in the struct, once at the 
top and once at the bottom. It's fine IMO but maybe the second could be "More fields valid in all RTEs"?

The new order of fields in RangleTblEntry matches the intro comment, which seems like another small 
benefit.

It seems like we are moving away from ever putting RTEKind-specific fields into a union as suggested 
by the FIXME comment here. It was written in 2002. Is it time to remove it?

This now needs to say "above" not "below":

     /*
      * join_using_alias is an alias clause attached directly to JOIN/USING. It
      * is different from the alias field (below) in that it does not hide the
      * range variables of the tables being joined.
      */
     Alias      *join_using_alias pg_node_attr(query_jumble_ignore);

Re bloating the serialization output, we could leave this last patch until after the work on that 
other thread is done to skip default-valued items.

Yours,

-- 
Paul              ~{:-)
[email-masked]

---

From: Matthias van de Meent <[email-masked]>
Date: Sun, 18 Feb 2024 00:06:19 +0100

> other thread is done to skip default-valued items.

I'm not sure that the cleanup which is done when changing a RTE's
rtekind is also complete enough for this purpose.
Things like inline_cte_walker change the node->rtekind, which could
leave residual junk data in fields that are currently dropped during
serialization (as the rtekind specifically ignores those fields), but
which would add overhead when the default omission is expected to
handle these fields; as they could then contain junk. It looks like
there is some care about zeroing now unused fields, but I haven't
checked that it covers all cases and fields to the extent required so
that removing this specialized serializer would have zero impact on
size once the default omission patch is committed.

An additional patch with a single function that for this purpose
clears junk fields from RTEs that changed kind would be appreciated:
it is often hand-coded at those locations the kind changes, but that's
more sensitive to programmer error.

Kind regards,

Matthias van de Meent