Subject: Re: documentation structure

From: "David G. Johnston" <[email-masked]>
Date: Fri, 5 Apr 2024 09:14:56 -0700

On Fri, Apr 5, 2024 at 9:01 AM Robert Haas <[email-masked]> wrote:

>
> > The rendering can be adjusted to some degree, but then we also need to
> > make sure any new chunking makes sense in other chapters.  (And it might
> > also change a bunch of externally known HTML links.)
>
> I looked into this and I'm unclear how much customization is possible.
>
>
Here is a link to my attempt at this a couple of years ago.  It basically
"abuses" refentry.

https://www.postgresql.org/message-id/CAKFQuwaVm%3D6d_sw9Wrp4cdSm5_k%3D8ZVx0--v2v4BH4KnJtqXqg%40mail.gmail.com

I never did dive into the man page or PDF dynamics of this
particular change but it seemed to solve HTML pagination without negative
consequences and with minimal risk of unintended consequences since only
the markup on the pages we want to alter is changed, not global
configuration.

David J.

---

From: Robert Haas <[email-masked]>
Date: Fri, 5 Apr 2024 12:18:30 -0400

On Fri, Apr 5, 2024 at 12:15 PM David G. Johnston
<[email-masked]> wrote:
> Here is a link to my attempt at this a couple of years ago.  It basically "abuses" refentry.
>
> I never did dive into the man page or PDF dynamics of this particular change but it seemed to solve HTML pagination without negative consequences and with minimal risk of unintended consequences since only the markup on the pages we want to alter is changed, not global configuration.

Hmm, but it seems like that might have generated some man page entries
that we don't want?

-- 
Robert Haas
EDB: http://www.enterprisedb.com

---

From: "David G. Johnston" <[email-masked]>
Date: Fri, 5 Apr 2024 09:22:36 -0700

On Fri, Apr 5, 2024 at 9:18 AM Robert Haas <[email-masked]> wrote:

> > I never did dive into the man page or PDF dynamics of this particular
> change but it seemed to solve HTML pagination without negative consequences
> and with minimal risk of unintended consequences since only the markup on
> the pages we want to alter is changed, not global configuration.
>

If so (didn't check) maybe just remove them in post?

David J.