Subject: Re: Potential null pointer dereference in postgres.c

From: Maxim Orlov <[email-masked]>
Date: Fri, 6 Dec 2024 18:52:20 +0300

I'm glad you are bringing up this issue. By the way, there are two more
annoying places in postmaster.c for pg16 and older. See, strdup() also may
fail if insufficient memory available.

PFA patch for a REL_16_STABLE. It also applies to older versions.

-- 
Best regards,
Maxim Orlov.

---

From: Maxim Orlov <[email-masked]>
Date: Fri, 10 Jan 2025 14:08:51 +0300

I have to admit I was wrong with previous v2 patch. Sorry.
Apparently, the chances of committing this very low, but here is the
correct one.

-- 
Best regards,
Maxim Orlov.