Subject: Re: [DOCS] Stats views and functions not in order?

From: Peter Smith <[email-masked]>
Date: Wed, 11 Jan 2023 17:11:38 +1100

On Wed, Jan 4, 2023 at 6:08 PM vignesh C <[email-masked]> wrote:
>
> On Mon, 2 Jan 2023 at 13:47, Peter Eisentraut
> <[email-masked]> wrote:
> >
> > On 08.12.22 03:30, Peter Smith wrote:
> > > PSA patches for v9*
> > >
> > > v9-0001 - Now the table rows are ordered per PeterE's suggestions [1]
> >
> > committed

Thanks for pushing.

> >
> > > v9-0002 - All the review comments from DavidJ [2] are addressed
> >
> > I'm not sure about this one.  It removes the "see [link] for details"
> > phrases and instead makes the view name a link.  I think this loses the
> > cue that there is more information elsewhere.  Otherwise, one could
> > think that, say, the entry about pg_stat_activity is the primary source
> > and the link just links to itself.  Also keep in mind that people use
> > media where links are not that apparent (PDF), so the presence of a link
> > by itself cannot be the only cue about the flow of the information.
>

PSA new patch for v10-0001

v9-0001 --> pushed, thanks!
v9-0002 --> I removed this based on the reject reason above
v9-0003 --> v10-0001

> I'm not sure if anything is pending for v9-0003, if there is something
> pending, please post an updated patch for the same.
>

Thanks for the reminder. PSA v10.

------
Kind Regards,
Peter Smith.
Fujitsu Australia

---

From: Peter Eisentraut <[email-masked]>
Date: Wed, 18 Jan 2023 11:36:18 +0100

> Thanks for the reminder. PSA v10.

So this patch changes some sections describing system views to 
refentry's.  What is the reason for that?  refentry's are basically man 
pages; do we want man pages for each system view?

Maybe (*), but then we should also do the same to all the other system 
views, all the system catalogs, everything else.  Just changing a few in 
a single place seems odd.

(*) -- but also maybe not?