Subject: Re: PATCH: Batch/pipelining support for libpq

From: Daniel Gustafsson <[email-masked]>
Date: Mon, 2 Oct 2017 11:31:07 +0200

> On 13 Sep 2017, at 07:44, Vaishnavi Prabakaran <[email-masked]> wrote:
> 
> On Wed, Sep 13, 2017 at 3:33 PM, Craig Ringer <[email-masked] <mailto:[email-masked]>> wrote:
> 
> I really do not like calling it "commit" as that conflates with a database commit.
> 
> A batch can embed multiple BEGINs and COMMITs. It's entirely possible for an earlier part of the batch to succeed and commit, then a later part to fail, if that's the case. So that name is IMO wrong.
> 
> Ok, SendQueue seems ok to me as well. Will change it in next version. 
>  
> +"a"?
> 
> Hmm, Can you explain the question please. I don't understand.
> 
> s/of new query/of a new query/
> 
> Thanks for explaining. Will change this too in next version. 

Based on the discussions in this thread, and that a new version hasn’t been
submitted, I’m marking this Returned with Feedback.  Please re-submit the new
version in an upcoming commitfest when ready.

cheers ./daniel

-- 
Sent via pgsql-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-hackers

---

From: Vaishnavi Prabakaran <[email-masked]>
Date: Thu, 5 Oct 2017 11:58:46 +1100

On Mon, Oct 2, 2017 at 8:31 PM, Daniel Gustafsson <[email-masked]> wrote:

> > A batch can embed multiple BEGINs and COMMITs. It's entirely possible
> for an earlier part of the batch to succeed and commit, then a later part
> to fail, if that's the case. So that name is IMO wrong.
> >

Thanks for the suggestion and, OK I will create a new patch in upcoming
commitfest with attached patch addressing above review comments.

Thanks & Regards,
Vaishnavi,
Fujitsu Australia.