Subject: Re: Problems with estimating OR conditions, IS NULL on LEFT JOINs

From: Tom Lane <[email-masked]>
Date: Fri, 23 Jun 2023 20:08:34 -0400

Tomas Vondra <[email-masked]> writes:
> The problem is that the selectivity for "IS NULL" is estimated using the
> table-level statistics. But the LEFT JOIN entirely breaks the idea that
> the null_frac has anything to do with NULLs in the join result.

Right.

> I wonder how to improve this, say by adjusting the IS NULL selectivity
> when we know to operate on the outer side of the join. We're able to
> do this for antijoins, so maybe we could do that here, somehow?

This mess is part of the long-term plan around the work I've been doing
on outer-join-aware Vars.  We now have infrastructure that can let
the estimator routines see "oh, this Var isn't directly from a scan
of its table, it's been passed through a potentially-nulling outer
join --- and I can see which one".  I don't have more than vague ideas
about what happens next, but that is clearly an essential step on the
road to doing better.

			regards, tom lane

---

From: Tomas Vondra <[email-masked]>
Date: Sat, 24 Jun 2023 13:23:23 +0200

> about what happens next, but that is clearly an essential step on the

I was wondering if that work on outer-join-aware Vars could help with
this, but I wasn't following it very closely. I agree the ability to
check if the Var could be NULL due to an outer join seems useful, as it
says whether applying raw attribute statistics makes sense or not.

I was thinking about what to do for the case when that's not possible,
i.e. when the Var refers to nullable side of the join. Knowing that this
is happening is clearly not enough - we need to know how many new NULLs
are "injected" into the join result, and "communicate" that to the
estimation routines.

Attached is a very ugly experimental patch doing that, and with it the
estimate changes to this:

                                 QUERY PLAN
  ----------------------------------------------------------------------
   Hash Left Join  (cost=3.25..18179.88 rows=999900 width=16)
                   (actual time=0.528..596.151 rows=999900 loops=1)
     Hash Cond: (large.id = small.id)
     Filter: ((small.id IS NULL) OR
              (large.a = ANY ('{1000,2000,3000,4000,5000}'::integer[])))
     Rows Removed by Filter: 100
     ->  Seq Scan on large  (cost=0.00..14425.00 rows=1000000 width=8)
                     (actual time=0.069..176.138 rows=1000000 loops=1)
     ->  Hash  (cost=2.00..2.00 rows=100 width=8)
               (actual time=0.371..0.373 rows=100 loops=1)
           Buckets: 1024  Batches: 1  Memory Usage: 12kB
           ->  Seq Scan on small  (cost=0.00..2.00 rows=100 width=8)
                         (actual time=0.032..0.146 rows=100 loops=1)
   Planning Time: 3.845 ms
   Execution Time: 712.405 ms
  (10 rows)

Seems nice, but. The patch is pretty ugly, I don't claim it works for
other queries or that this is exactly what we should do. It calculates
"unmatched frequency" next to eqjoinsel_inner, stashes that info into
sjinfo and the estimator (nulltestsel) then uses that to adjust the
nullfrac it gets from the statistics.

The good thing is this helps even for IS NULL checks on non-join-key
columns (where we don't switch to an antijoin), but there's a couple
things that I dislike ...

1) It's not restricted to outer joins or anything like that (this is
mostly just my laziness / interest in one particular query, but also
something the outer-join-aware patch might help with).

2) We probably don't want to pass this kind of information through
sjinfo. That was the simplest thing for an experimental patch, but I
suspect it's not the only piece of information we may need to pass to
the lower levels of estimation code.

3) I kinda doubt we actually want to move this responsibility (to
consider fraction of unmatched rows) to the low-level estimation
routines (e.g. nulltestsel and various others). AFAICS this just
"introduces NULLs" into the relation, so maybe we could "adjust" the
attribute statistics (in examine_variable?) by inflating null_frac and
modifying the other frequencies in MCV/histogram.

4) But I'm not sure we actually want to do that in these low-level
selectivity functions. The outer join essentially produces output with
two subsets - one with matches on the outer side, one without them. But
the side without matches has NULLs in all columns. In a way, we know
exactly how are these columns correlated - if we do the usual estimation
(even with the null_frac adjusted), we just throw this information away.
And when there's a lot of rows without a match, that seems bad.

So maybe we should split the join estimate into two parts, one for each
subset of the join result. One for the rows with a match (and then we
can just do what we do now, with the attribute stats we already have).
And one for the "unmatched part" where we know the values on the outer
side are NULL (and then we can easily "fake" stats with null_frac=1.0).

I really hope what I just wrote makes at least a little bit of sense.

regards

-- 
Tomas Vondra
EnterpriseDB: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

diff --git a/src/backend/utils/adt/selfuncs.c b/src/backend/utils/adt/selfuncs.c
index c4fcd0076e..a035e213a0 100644
--- a/src/backend/utils/adt/selfuncs.c
+++ b/src/backend/utils/adt/selfuncs.c
@@ -154,6 +154,13 @@ static double eqjoinsel_inner(Oid opfuncoid, Oid collation,
 							  AttStatsSlot *sslot1, AttStatsSlot *sslot2,
 							  Form_pg_statistic stats1, Form_pg_statistic stats2,
 							  bool have_mcvs1, bool have_mcvs2);
+static double eqjoinsel_unmatch_left(Oid opfuncoid, Oid collation,
+									 VariableStatData *vardata1, VariableStatData *vardata2,
+									 double nd1, double nd2,
+									 bool isdefault1, bool isdefault2,
+									 AttStatsSlot *sslot1, AttStatsSlot *sslot2,
+									 Form_pg_statistic stats1, Form_pg_statistic stats2,
+									 bool have_mcvs1, bool have_mcvs2);
 static double eqjoinsel_semi(Oid opfuncoid, Oid collation,
 							 VariableStatData *vardata1, VariableStatData *vardata2,
 							 double nd1, double nd2,
@@ -1710,6 +1717,9 @@ nulltestsel(PlannerInfo *root, NullTestType nulltesttype, Node *arg,
 		stats = (Form_pg_statistic) GETSTRUCT(vardata.statsTuple);
 		freq_null = stats->stanullfrac;
 
+		if (sjinfo)
+			freq_null = freq_null + sjinfo->unmatched_frac - freq_null * sjinfo->unmatched_frac;
+
 		switch (nulltesttype)
 		{
 			case IS_NULL:
@@ -2249,6 +2259,7 @@ eqjoinsel(PG_FUNCTION_ARGS)
 	Oid			collation = PG_GET_COLLATION();
 	double		selec;
 	double		selec_inner;
+	double		unmatched_frac;
 	VariableStatData vardata1;
 	VariableStatData vardata2;
 	double		nd1;
@@ -2321,6 +2332,26 @@ eqjoinsel(PG_FUNCTION_ARGS)
 								  stats1, stats2,
 								  have_mcvs1, have_mcvs2);
 
+	/*
+	 * calculate fraction of right without of matching row on left
+	 *
+	 * FIXME Should be restricted to JOIN_LEFT, we should have similar logic
+	 * for JOIN_FULL.
+	 *
+	 * XXX Probably should calculate unmatched as fraction of the join result,
+	 * not of the relation on the right (because the matched part can have more
+	 * matches per row and thus grow). Not sure. Depends on how it's used later.
+	 */
+	unmatched_frac = eqjoinsel_unmatch_left(opfuncoid, collation,
+											&vardata1, &vardata2,
+											nd1, nd2,
+											isdefault1, isdefault2,
+											&sslot1, &sslot2,
+											stats1, stats2,
+											have_mcvs1, have_mcvs2);
+
+	sjinfo->unmatched_frac = unmatched_frac;
+
 	switch (sjinfo->jointype)
 	{
 		case JOIN_INNER:
@@ -2590,6 +2621,117 @@ eqjoinsel_inner(Oid opfuncoid, Oid collation,
 	return selec;
 }
 
+/*
+ * eqjoinsel_unmatch_left
+ *
+ * XXX Mostly copy paste of eqjoinsel_inner, but calculates unmatched fraction
+ * of the relation on the left. See eqjoinsel_inner for more comments.
+ *
+ * XXX Maybe we could/should integrate this into eqjoinsel_inner, so that we
+ * don't have to walk the MCV lists twice?
+ */
+static double
+eqjoinsel_unmatch_left(Oid opfuncoid, Oid collation,
+					   VariableStatData *vardata1, VariableStatData *vardata2,
+					   double nd1, double nd2,
+					   bool isdefault1, bool isdefault2,
+					   AttStatsSlot *sslot1, AttStatsSlot *sslot2,
+					   Form_pg_statistic stats1, Form_pg_statistic stats2,
+					   bool have_mcvs1, bool have_mcvs2)
+{
+	double		unmatchfreq;
+
+	if (have_mcvs1 && have_mcvs2)
+	{
+		LOCAL_FCINFO(fcinfo, 2);
+		FmgrInfo	eqproc;
+		bool	   *hasmatch1;
+		bool	   *hasmatch2;
+		double		matchprodfreq,
+					matchfreq1,
+					unmatchfreq1;
+		int			i,
+					nmatches;
+
+		fmgr_info(opfuncoid, &eqproc);
+
+		/*
+		 * Save a few cycles by setting up the fcinfo struct just once. Using
+		 * FunctionCallInvoke directly also avoids failure if the eqproc
+		 * returns NULL, though really equality functions should never do
+		 * that.
+		 */
+		InitFunctionCallInfoData(*fcinfo, &eqproc, 2, collation,
+								 NULL, NULL);
+		fcinfo->args[0].isnull = false;
+		fcinfo->args[1].isnull = false;
+
+		hasmatch1 = (bool *) palloc0(sslot1->nvalues * sizeof(bool));
+		hasmatch2 = (bool *) palloc0(sslot2->nvalues * sizeof(bool));
+
+		/*
+		 * Note we assume that each MCV will match at most one member of the
+		 * other MCV list.  If the operator isn't really equality, there could
+		 * be multiple matches --- but we don't look for them, both for speed
+		 * and because the math wouldn't add up...
+		 */
+		matchprodfreq = 0.0;
+		nmatches = 0;
+		for (i = 0; i < sslot1->nvalues; i++)
+		{
+			int			j;
+
+			fcinfo->args[0].value = sslot1->values[i];
+
+			for (j = 0; j < sslot2->nvalues; j++)
+			{
+				Datum		fresult;
+
+				if (hasmatch2[j])
+					continue;
+				fcinfo->args[1].value = sslot2->values[j];
+				fcinfo->isnull = false;
+				fresult = FunctionCallInvoke(fcinfo);
+				if (!fcinfo->isnull && DatumGetBool(fresult))
+				{
+					hasmatch1[i] = hasmatch2[j] = true;
+					matchprodfreq += sslot1->numbers[i] * sslot2->numbers[j];
+					nmatches++;
+					break;
+				}
+			}
+		}
+		CLAMP_PROBABILITY(matchprodfreq);
+		/* Sum up frequencies of matched and unmatched MCVs */
+		matchfreq1 = unmatchfreq1 = 0.0;
+		for (i = 0; i < sslot1->nvalues; i++)
+		{
+			if (hasmatch1[i])
+				matchfreq1 += sslot1->numbers[i];
+			else
+				unmatchfreq1 += sslot1->numbers[i];
+		}
+		CLAMP_PROBABILITY(matchfreq1);
+		CLAMP_PROBABILITY(unmatchfreq1);
+
+		unmatchfreq = unmatchfreq1;
+	}
+	else
+	{
+		/*
+		 * XXX Should this look at nullfrac on either side? Probably depends on
+		 * if we're calculating fraction of NULLs or fraction of unmatched rows.
+		 */
+		// unmatchfreq = (1.0 - nullfrac1) * (1.0 - nullfrac2);
+		if (nd1 > nd2)
+			unmatchfreq = (nd1 - nd2) * 1.0 / nd1;
+		else
+			unmatchfreq = 0.0;
+	}
+
+	return unmatchfreq;
+}
+
 /*
  * eqjoinsel_semi --- eqjoinsel for semi join
  *
diff --git a/src/include/nodes/pathnodes.h b/src/include/nodes/pathnodes.h
index c17b53f7ad..6bc63e648e 100644
--- a/src/include/nodes/pathnodes.h
+++ b/src/include/nodes/pathnodes.h
@@ -2853,6 +2853,9 @@ struct SpecialJoinInfo
 	bool		semi_can_hash;	/* true if semi_operators are all hash */
 	List	   *semi_operators; /* OIDs of equality join operators */
 	List	   *semi_rhs_exprs; /* righthand-side expressions of these ops */
+
+	/* For outer join, fraction of rows without a match. */
+	Selectivity	unmatched_frac;
 };
 
 /*

---

From: Andrey Lepikhov <[email-masked]>
Date: Mon, 26 Jun 2023 15:22:03 +0600

> I really hope what I just wrote makes at least a little bit of sense.
Throw in one more example:

SELECT i AS id INTO l FROM generate_series(1,100000) i;
CREATE TABLE r (id int8, v text);
INSERT INTO r (id, v) VALUES (1, 't'), (-1, 'f');
ANALYZE l,r;
EXPLAIN ANALYZE
SELECT * FROM l LEFT OUTER JOIN r ON (r.id = l.id) WHERE r.v IS NULL;

Here you can see the same kind of underestimation:
Hash Left Join  (... rows=500 width=14) (... rows=99999 ...)

So the eqjoinsel_unmatch_left() function should be modified for the case 
where nd1<nd2.

-- 
regards,
Andrey Lepikhov
Postgres Professional

---

From: Alena Rybakina <[email-masked]>
Date: Mon, 26 Jun 2023 21:15:07 +0300

Hi, all!

On 24.06.2023 14:23, Tomas Vondra wrote:
>> Tomas Vondra<[email-masked]>  writes:
I am also interested in this problem.

I did some refactoring of the source code in the patch, moved the 
calculation of unmatched_fraction to eqjoinsel_inner.
I wrote myself in this commit as a co-author, if you don't mind, and I'm 
going to continue working.

On 26.06.2023 12:22, Andrey Lepikhov wrote:
> So the eqjoinsel_unmatch_left() function should be modified for the 
> case where nd1<nd2.
>
Unfortunately, this patch could not fix the cardinality calculation in 
this request, I'll try to look and figure out what is missing here.

*postgres=# SELECT i AS id INTO l FROM generate_series(1,100000) i;
CREATE TABLE r (id int8, v text);
INSERT INTO r (id, v) VALUES (1, 't'), (-1, 'f');
ANALYZE l,r;
EXPLAIN ANALYZE
SELECT * FROM l LEFT OUTER JOIN r ON (r.id = l.id) WHERE r.v IS NULL;
SELECT 100000
CREATE TABLE
INSERT 0 2
ANALYZE
                                                   QUERY PLAN
---------------------------------------------------------------------------------------------------------------
  Hash Left Join  (cost=1.04..1819.07 rows=1 width=14) (actual 
time=0.143..114.792 rows=99999 loops=1)
    Hash Cond: (l.id = r.id)
    Filter: (r.v IS NULL)
    Rows Removed by Filter: 1
    ->  Seq Scan on l  (cost=0.00..1443.00 rows=100000 width=4) (actual 
time=0.027..35.278 rows=100000 loops=1)
    ->  Hash  (cost=1.02..1.02 rows=2 width=10) (actual 
time=0.014..0.017 rows=2 loops=1)
          Buckets: 1024  Batches: 1  Memory Usage: 9kB
          ->  Seq Scan on r  (cost=0.00..1.02 rows=2 width=10) (actual 
time=0.005..0.007 rows=2 loops=1)
  Planning Time: 0.900 ms
  Execution Time: 126.180 ms
(10 rows)*

As in the previous query, even with applied the patch, the cardinality 
is calculated poorly here, I would even say that it has become worse:

EXPLAIN ANALYZE
   SELECT * FROM large FULL JOIN small ON (large.id = small.id)
WHERE (large.a IS NULL);

MASTER:

*QUERY PLAN
-----------------------------------------------------------------------------------------------------------------------------------
  Merge Full Join  (cost=127921.69..299941.59 rows=56503 width=16) 
(actual time=795.092..795.094 rows=0 loops=1)
    Merge Cond: (small.id = large.id)
    Filter: (large.a IS NULL)
    Rows Removed by Filter: 1000000
    ->  Sort  (cost=158.51..164.16 rows=2260 width=8) (actual 
time=0.038..0.046 rows=100 loops=1)
          Sort Key: small.id
          Sort Method: quicksort  Memory: 29kB
          ->  Seq Scan on small  (cost=0.00..32.60 rows=2260 width=8) 
(actual time=0.013..0.022 rows=100 loops=1)
    ->  Materialize  (cost=127763.19..132763.44 rows=1000050 width=8) 
(actual time=363.016..649.103 rows=1000000 loops=1)
          ->  Sort  (cost=127763.19..130263.31 rows=1000050 width=8) 
(actual time=363.012..481.480 rows=1000000 loops=1)
                Sort Key: large.id
                Sort Method: external merge  Disk: 17664kB
                ->  Seq Scan on large (cost=0.00..14425.50 rows=1000050 
width=8) (actual time=0.009..111.166 rows=1000000 loops=1)
  Planning Time: 0.124 ms
  Execution Time: 797.139 ms
(15 rows)*

With patch:

*QUERY PLAN
----------------------------------------------------------------------------------------------------------------------
  Hash Full Join  (cost=3.25..18179.25 rows=999900 width=16) (actual 
time=261.480..261.482 rows=0 loops=1)
    Hash Cond: (large.id = small.id)
    Filter: (large.a IS NULL)
    Rows Removed by Filter: 1000000
    ->  Seq Scan on large  (cost=0.00..14425.00 rows=1000000 width=8) 
(actual time=0.006..92.827 rows=1000000 loops=1)
    ->  Hash  (cost=2.00..2.00 rows=100 width=8) (actual 
time=0.032..0.034 rows=100 loops=1)
          Buckets: 1024  Batches: 1  Memory Usage: 12kB
          ->  Seq Scan on small  (cost=0.00..2.00 rows=100 width=8) 
(actual time=0.008..0.015 rows=100 loops=1)
  Planning Time: 0.151 ms
  Execution Time: 261.529 ms
(10 rows)
*

In addition, I found a few more queries, where the estimation of 
cardinality with the patch has become better:

EXPLAIN ANALYZE
   SELECT * FROM small LEFT JOIN large ON (large.id = small.id)
WHERE (small.b IS NULL);

MASTER:

*QUERY PLAN
-------------------------------------------------------------------------------------------------------------
  Hash Right Join  (cost=32.74..18758.45 rows=55003 width=16) (actual 
time=0.100..0.104 rows=0 loops=1)
    Hash Cond: (large.id = small.id)
    ->  Seq Scan on large  (cost=0.00..14425.50 rows=1000050 width=8) 
(never executed)
    ->  Hash  (cost=32.60..32.60 rows=11 width=8) (actual 
time=0.089..0.091 rows=0 loops=1)
          Buckets: 1024  Batches: 1  Memory Usage: 8kB
          ->  Seq Scan on small  (cost=0.00..32.60 rows=11 width=8) 
(actual time=0.088..0.088 rows=0 loops=1)
                Filter: (b IS NULL)
                Rows Removed by Filter: 100
  Planning Time: 0.312 ms
  Execution Time: 0.192 ms
(10 rows)*

With patch:

*QUERY PLAN
-----------------------------------------------------------------------------------------------------------
  Hash Right Join  (cost=2.01..18177.02 rows=1 width=16) (actual 
time=0.127..0.132 rows=0 loops=1)
    Hash Cond: (large.id = small.id)
    ->  Seq Scan on large  (cost=0.00..14425.00 rows=1000000 width=8) 
(never executed)
    ->  Hash  (cost=2.00..2.00 rows=1 width=8) (actual time=0.112..0.114 
rows=0 loops=1)
          Buckets: 1024  Batches: 1  Memory Usage: 8kB
          ->  Seq Scan on small  (cost=0.00..2.00 rows=1 width=8) 
(actual time=0.111..0.111 rows=0 loops=1)
                Filter: (b IS NULL)
                Rows Removed by Filter: 100
  Planning Time: 0.984 ms
  Execution Time: 0.237 ms
(10 rows)*

EXPLAIN ANALYZE
   SELECT * FROM large FULL JOIN small ON (large.id = small.id)
WHERE (small.b IS NULL);

MASTER:

*QUERY PLAN
-----------------------------------------------------------------------------------------------------------------------------------
  Merge Full Join  (cost=127921.69..299941.59 rows=56503 width=16) 
(actual time=339.478..819.232 rows=999900 loops=1)
    Merge Cond: (small.id = large.id)
    Filter: (small.b IS NULL)
    Rows Removed by Filter: 100
    ->  Sort  (cost=158.51..164.16 rows=2260 width=8) (actual 
time=0.129..0.136 rows=100 loops=1)
          Sort Key: small.id
          Sort Method: quicksort  Memory: 29kB
          ->  Seq Scan on small  (cost=0.00..32.60 rows=2260 width=8) 
(actual time=0.044..0.075 rows=100 loops=1)
    ->  Materialize  (cost=127763.19..132763.44 rows=1000050 width=8) 
(actual time=339.260..605.444 rows=1000000 loops=1)
          ->  Sort  (cost=127763.19..130263.31 rows=1000050 width=8) 
(actual time=339.254..449.930 rows=1000000 loops=1)
                Sort Key: large.id
                Sort Method: external merge  Disk: 17664kB
                ->  Seq Scan on large (cost=0.00..14425.50 rows=1000050 
width=8) (actual time=0.032..104.484 rows=1000000 loops=1)
  Planning Time: 0.324 ms
  Execution Time: 859.705 ms
(15 rows)
*

With patch:

*QUERY PLAN
----------------------------------------------------------------------------------------------------------------------
  Hash Full Join  (cost=3.25..18179.25 rows=999900 width=16) (actual 
time=0.162..349.683 rows=999900 loops=1)
    Hash Cond: (large.id = small.id)
    Filter: (small.b IS NULL)
    Rows Removed by Filter: 100
    ->  Seq Scan on large  (cost=0.00..14425.00 rows=1000000 width=8) 
(actual time=0.021..95.972 rows=1000000 loops=1)
    ->  Hash  (cost=2.00..2.00 rows=100 width=8) (actual 
time=0.125..0.127 rows=100 loops=1)
          Buckets: 1024  Batches: 1  Memory Usage: 12kB
          ->  Seq Scan on small  (cost=0.00..2.00 rows=100 width=8) 
(actual time=0.030..0.059 rows=100 loops=1)
  Planning Time: 0.218 ms
  Execution Time: 385.819 ms
(10 rows)
*

**

EXPLAIN ANALYZE
   SELECT * FROM large RIGHT JOIN small ON (large.id = small.id)
   WHERE (large.a IS NULL);

MASTER:

*QUERY PLAN
-----------------------------------------------------------------------------------------------------------------------------------
  Merge Left Join  (cost=127921.69..299941.59 rows=56503 width=16) 
(actual time=345.403..345.404 rows=0 loops=1)
    Merge Cond: (small.id = large.id)
    Filter: (large.a IS NULL)
    Rows Removed by Filter: 100
    ->  Sort  (cost=158.51..164.16 rows=2260 width=8) (actual 
time=0.033..0.039 rows=100 loops=1)
          Sort Key: small.id
          Sort Method: quicksort  Memory: 29kB
          ->  Seq Scan on small  (cost=0.00..32.60 rows=2260 width=8) 
(actual time=0.012..0.020 rows=100 loops=1)
    ->  Materialize  (cost=127763.19..132763.44 rows=1000050 width=8) 
(actual time=345.287..345.315 rows=101 loops=1)
          ->  Sort  (cost=127763.19..130263.31 rows=1000050 width=8) 
(actual time=345.283..345.295 rows=101 loops=1)
                Sort Key: large.id
                Sort Method: external merge  Disk: 17664kB
                ->  Seq Scan on large (cost=0.00..14425.50 rows=1000050 
width=8) (actual time=0.009..104.648 rows=1000000 loops=1)
  Planning Time: 0.098 ms
  Execution Time: 347.807 ms
(15 rows)*

With patch:

*QUERY PLAN
----------------------------------------------------------------------------------------------------------------------
  Hash Right Join  (cost=3.25..18179.25 rows=100 width=16) (actual 
time=209.838..209.842 rows=0 loops=1)
    Hash Cond: (large.id = small.id)
    Filter: (large.a IS NULL)
    Rows Removed by Filter: 100
    ->  Seq Scan on large  (cost=0.00..14425.00 rows=1000000 width=8) 
(actual time=0.006..91.571 rows=1000000 loops=1)
    ->  Hash  (cost=2.00..2.00 rows=100 width=8) (actual 
time=0.034..0.036 rows=100 loops=1)
          Buckets: 1024  Batches: 1  Memory Usage: 12kB
          ->  Seq Scan on small  (cost=0.00..2.00 rows=100 width=8) 
(actual time=0.008..0.016 rows=100 loops=1)
  Planning Time: 0.168 ms
  Execution Time: 209.883 ms
(10 rows)*
From e8653477fbe7321325122a2d5032798cd6a95a8b Mon Sep 17 00:00:00 2001
From: Tomas Vondra <[email-masked]>
Date: Mon, 26 Jun 2023 15:39:11 +0300
Subject: [PATCH] Fixed the case of calculating underestimated cardinality for
 an LEFT JOIN with the restriction "IS NULL" in the clause. This error is
 caused by an incorrect calculation of selectivity in the "IS NULL" clause,
 since it took into account only table-level statistics without zero values in
 the results of the join operation. This patch fixes this by calculating the
 fraction of zero values on the right side of the join without of matching row
 on left.

Co-authored-by: Alena Rybakina <[email-masked]>
---
 src/backend/utils/adt/selfuncs.c | 35 +++++++++++++++++++++++++++++---
 src/include/nodes/pathnodes.h    |  3 +++
 2 files changed, 35 insertions(+), 3 deletions(-)

diff --git a/src/backend/utils/adt/selfuncs.c b/src/backend/utils/adt/selfuncs.c
index c4fcd0076ea..8e18aa1dd2b 100644
--- a/src/backend/utils/adt/selfuncs.c
+++ b/src/backend/utils/adt/selfuncs.c
@@ -153,7 +153,7 @@ static double eqjoinsel_inner(Oid opfuncoid, Oid collation,
 							  bool isdefault1, bool isdefault2,
 							  AttStatsSlot *sslot1, AttStatsSlot *sslot2,
 							  Form_pg_statistic stats1, Form_pg_statistic stats2,
-							  bool have_mcvs1, bool have_mcvs2);
+							  bool have_mcvs1, bool have_mcvs2, double *unmatched_frac);
 static double eqjoinsel_semi(Oid opfuncoid, Oid collation,
 							 VariableStatData *vardata1, VariableStatData *vardata2,
 							 double nd1, double nd2,
@@ -1710,6 +1710,9 @@ nulltestsel(PlannerInfo *root, NullTestType nulltesttype, Node *arg,
 		stats = (Form_pg_statistic) GETSTRUCT(vardata.statsTuple);
 		freq_null = stats->stanullfrac;
 
+		if (sjinfo)
+			freq_null = freq_null + sjinfo->unmatched_frac - freq_null * sjinfo->unmatched_frac;
+
 		switch (nulltesttype)
 		{
 			case IS_NULL:
@@ -2313,13 +2316,24 @@ eqjoinsel(PG_FUNCTION_ARGS)
 	}
 
 	/* We need to compute the inner-join selectivity in all cases */
+	/*
+	 * calculate fraction of right without of matching row on left
+	 *
+	 * FIXME Should be restricted to JOIN_LEFT, we should have similar logic
+	 * for JOIN_FULL.
+	 *
+	 * XXX Probably should calculate unmatched as fraction of the join result,
+	 * not of the relation on the right (because the matched part can have more
+	 * matches per row and thus grow). Not sure. Depends on how it's used later.
+	 */
 	selec_inner = eqjoinsel_inner(opfuncoid, collation,
 								  &vardata1, &vardata2,
 								  nd1, nd2,
 								  isdefault1, isdefault2,
 								  &sslot1, &sslot2,
 								  stats1, stats2,
-								  have_mcvs1, have_mcvs2);
+								  have_mcvs1, have_mcvs2,
+								  &sjinfo->unmatched_frac);
 
 	switch (sjinfo->jointype)
 	{
@@ -2407,7 +2421,7 @@ eqjoinsel_inner(Oid opfuncoid, Oid collation,
 				bool isdefault1, bool isdefault2,
 				AttStatsSlot *sslot1, AttStatsSlot *sslot2,
 				Form_pg_statistic stats1, Form_pg_statistic stats2,
-				bool have_mcvs1, bool have_mcvs2)
+				bool have_mcvs1, bool have_mcvs2, double *unmatched_frac)
 {
 	double		selec;
 
@@ -2503,7 +2517,10 @@ eqjoinsel_inner(Oid opfuncoid, Oid collation,
 		}
 		CLAMP_PROBABILITY(matchfreq1);
 		CLAMP_PROBABILITY(unmatchfreq1);
+
+		*unmatched_frac = unmatchfreq1;
 		matchfreq2 = unmatchfreq2 = 0.0;
+
 		for (i = 0; i < sslot2->nvalues; i++)
 		{
 			if (hasmatch2[i])
@@ -2581,10 +2598,22 @@ eqjoinsel_inner(Oid opfuncoid, Oid collation,
 		double		nullfrac2 = stats2 ? stats2->stanullfrac : 0.0;
 
 		selec = (1.0 - nullfrac1) * (1.0 - nullfrac2);
+
+		/*
+		 * XXX Should this look at nullfrac on either side? Probably depends on
+		 * if we're calculating fraction of NULLs or fraction of unmatched rows.
+		 */
+		// unmatchfreq = (1.0 - nullfrac1) * (1.0 - nullfrac2);
 		if (nd1 > nd2)
+		{
 			selec /= nd1;
+			*unmatched_frac = (nd1 - nd2) * 1.0 / nd1;
+		}
 		else
+		{
 			selec /= nd2;
+			*unmatched_frac = 0.0;
+		}
 	}
 
 	return selec;
index c17b53f7adb..6bc63e648e6 100644
 
 /*
-- 
2.34.1

---

From: Tomas Vondra <[email-masked]>
Date: Wed, 28 Jun 2023 23:53:32 +0200

> going to continue working.

Sure, if you want to take over the patch and continue working on it,
that's perfectly fine with me. I'm happy to cooperate on it, doing
reviews etc.

>                                                   QUERY
> PLAN                                                   
>    ->  Hash  (cost=1.02..1.02 rows=2 width=10) (actual time=0.014..0.017
> rows=2 loops=1)
> *                                                              QUERY
> PLAN                                                         
> *                                                      QUERY
> PLAN                                                      

Yes, this does not surprise me at all - the patch was very early /
experimental code, and I only really aimed it at that single example
query. So don't hesitate to rethink what/how the patch works.

I do think collecting / constructing a wider set of queries with joins
of different types is going to be an important step in working on this
patch and making sure it doesn't break something.

regards

---

From: Alena Rybakina <[email-masked]>
Date: Thu, 6 Jul 2023 16:51:48 +0300

Hi, all!

> this request, I'll try to look and figure out what is missing here.

I tried to fix the cardinality score in the query above by changing:

diff --git a/src/backend/utils/adt/selfuncs.c 
b/src/backend/utils/adt/selfuncs.c
index 8e18aa1dd2b..40901836146 100644
--- a/src/backend/utils/adt/selfuncs.c
+++ b/src/backend/utils/adt/selfuncs.c
@@ -2604,11 +2604,16 @@ eqjoinsel_inner(Oid opfuncoid, Oid collation,
                  * if we're calculating fraction of NULLs or fraction 
of unmatched rows.
                  */
                 // unmatchfreq = (1.0 - nullfrac1) * (1.0 - nullfrac2);
-               if (nd1 > nd2)
+               if (nd1 != nd2)
                 {
-                       selec /= nd1;
-                       *unmatched_frac = (nd1 - nd2) * 1.0 / nd1;
+                       selec /= Max(nd1, nd2);
+                       *unmatched_frac = abs(nd1 - nd2) * 1.0 / 
Max(nd1, nd2);
                 }
+               /*if (nd1 > nd2)
+               {
+                       selec /= nd1;
+                       *unmatched_frac = nd1 - nd2 * 1.0 / nd1;
+               }*/
                 else
                 {
                         selec /= nd2;

and it worked:

SELECT i AS id INTO l FROM generate_series(1,100000) i;
CREATE TABLE r (id int8, v text);
INSERT INTO r (id, v) VALUES (1, 't'), (-1, 'f');
ANALYZE l,r;
EXPLAIN ANALYZE
SELECT * FROM l LEFT OUTER JOIN r ON (r.id = l.id) WHERE r.v IS NULL;
ERROR:  relation "l" already exists
ERROR:  relation "r" already exists
INSERT 0 2
ANALYZE
                                                   QUERY PLAN
---------------------------------------------------------------------------------------------------------------
  Hash Left Join  (cost=1.09..1944.13 rows=99998 width=14) (actual 
time=0.152..84.184 rows=99999 loops=1)
    Hash Cond: (l.id = r.id)
    Filter: (r.v IS NULL)
    Rows Removed by Filter: 2
    ->  Seq Scan on l  (cost=0.00..1443.00 rows=100000 width=4) (actual 
time=0.040..27.635 rows=100000 loops=1)
    ->  Hash  (cost=1.04..1.04 rows=4 width=10) (actual 
time=0.020..0.022 rows=4 loops=1)
          Buckets: 1024  Batches: 1  Memory Usage: 9kB
          ->  Seq Scan on r  (cost=0.00..1.04 rows=4 width=10) (actual 
time=0.009..0.011 rows=4 loops=1)
  Planning Time: 0.954 ms
  Execution Time: 92.309 ms
(10 rows)

It looks too simple and I suspect that I might have missed something 
somewhere, but so far I haven't found any examples of queries where it 
doesn't work.

I didn't see it breaking anything in the examples from my previous 
letter [1].

1. 
https://www.postgresql.org/message-id/7af1464e-2e24-cfb1-b6d4-1544757f8cfa%40yandex.ru

Unfortunately, I can't understand your idea from point 4, please explain it?

-- 
Regards,
Alena Rybakina
Postgres Professional
From 54a24390f1137a77c9755a875774a75ae8cf2424 Mon Sep 17 00:00:00 2001

Co-authored-by: Alena Rybakina <[email-masked]>
---
 src/backend/utils/adt/selfuncs.c | 39 ++++++++++++++++++++++++++++----
 src/include/nodes/pathnodes.h    |  3 +++
 2 files changed, 37 insertions(+), 5 deletions(-)

index c4fcd0076ea..a0e3834453b 100644
 
+		if (sjinfo)

 
 
 		selec = (1.0 - nullfrac1) * (1.0 - nullfrac2);
-		if (nd1 > nd2)
-			selec /= nd1;
+
+		/*
+		 * XXX Should this look at nullfrac on either side? Probably depends on
+		 * if we're calculating fraction of NULLs or fraction of unmatched rows.
+		 */
+		// unmatchfreq = (1.0 - nullfrac1) * (1.0 - nullfrac2);
+		if (nd1 != nd2)
+		{
+			selec /= Max(nd1, nd2);
+			*unmatched_frac = abs(nd1 - nd2) * 1.0 / Max(nd1, nd2);
+		}
 		else
+		{
 			selec /= nd2;
+			*unmatched_frac = 0.0;
+		}
 	}
 
 	return selec;
 
 /*
-- 
2.34.1

---

From: Tomas Vondra <[email-masked]>
Date: Thu, 6 Jul 2023 17:38:38 +0200

On 7/6/23 15:51, Alena Rybakina wrote:
>                  * if we're calculating fraction of NULLs or fraction of
> unmatched rows.
>                  */
>    ->  Hash  (cost=1.04..1.04 rows=4 width=10) (actual time=0.020..0.022
> rows=4 loops=1)

I think it's correct. Or at least it doesn't break anything my patch
didn't already break. My patch was simply written for one specific
query, so it didn't consider the option that the nd1 and nd2 values
might be in the opposite direction ...

> And when there's a lot of rows without a match, that seems bad.

Well, one option would be to modify all selectivity functions to do
something like the patch does for nulltestsel(). That seems a bit
cumbersome because why should those places care about maybe running on
the outer side of a join, or what? For code in extensions this would be
particularly problematic, I think.

So what I was thinking about doing this in a way that'd make this
automatic, without having to modify the selectivity functions.

Option (3) is very simple - examine_variable would simply adjust the
statistics by tweaking the null_frac field, when looking at variables on
the outer side of the join. But it has issues when estimating multiple
conditions.

Imagine t1 has 1M rows, and we want to estimate

  SELECT * FROM t1 LEFT JOIN t2 ON (t1.id = t2.id)
          WHERE ((t2.a=1) AND (t2.b=1))

but only 50% of the t1 rows has a match in t2. Assume each of the t2
conditions matches 100% rows in the table. With the correction, this
means 50% selectivity for each condition. And if we combine them the
usual way, it's 0.5 * 0.5 = 0.25.

But we know all the rows in the "matching" part match the condition, so
the correct selectivity should be 0.5.

In a way, this is just another case of estimation issues due to the
assumption of independence.

But (4) was suggesting we could improve this essentially by treating the
join as two distinct sets of rows

 - the inner join result

 - rows without match on the outer side

For the inner part, we would do estimates as now (using the regular
per-column statistics). If we knew the conditions match 100% rows, we'd
still get 100% when the conditions are combined.

For the second part of the join we know the outer side is just NULLs in
all columns, and that'd make the estimation much simpler for most
clauses. We'd just need to have "fake" statistics with null_frac=1.0 and
that's it.

And then we'd just combine these two selectivities. If we know the inner
side is 50% and all rows match the conditions, and no rows in the other
50% match, the selectivity is 50%.

inner_part * inner_sel + outer_part * outer_sel = 0.5 * 1.0 + 0.0 = 0.5

Now, we still have issues with independence assumption in each of these
parts separately. But that's OK, I think.

I think (4) could be implemented by doing the current estimation for the
 inner part, and by tweaking examine_variable in the "outer" part in a
way similar to (3). Except that it just sets null_frac=1.0 everywhere.

FWIW, I used "AND" in the example for simplicity, but that'd probably be
pushed to the baserel level. There'd need to be OR to keep it at the
join level, but the overall issue is the same, I think.

Also, this entirely ignores extended statistics - I have no idea how we
might tweak those in (3). For (4) we don't need to tweak those at all,
because for inner part we can just apply them as is, and for outer part
it's irrelevant because everything is NULL.

I hope this makes more sense. If not, let me know and I'll try to
explain it better.

regards