Subject: Re: Use pgstat_kind_infos to read fixed shared stats structs

From: "Tristan Partin" <[email-masked]>
Date: Tue, 07 May 2024 00:44:51 -0500

On Mon May 6, 2024 at 9:50 PM CDT, Michael Paquier wrote:
> On Mon, May 06, 2024 at 02:07:53PM -0500, Tristan Partin wrote:
> > This was originally thought of by Andres in
> > 5891c7a8ed8f2d3d577e7eea34dacff12d7b6bbd.
>
> +1 because you are removing a duplication between the order of the
> items in PgStat_Kind and the order when these are read.  I suspect
> that nobody would mess up with the order if adding a stats kind with a
> fixed number of objects, but that makes maintenance slightly easier in
> the long-term :)
>
> > Not a fix, per se, but it does remove a comment. Perhaps the discussion will
> > just lead to someone deleting the comment, and keeping the code as is.
> > Either way, a win :).
>
> Yup.  Let's leave that as something to do for v18.

Thanks for the feedback Michael. Should I just throw the patch in the 
next commitfest so it doesn't get left behind?

-- 
Tristan Partin
Neon (https://neon.tech)

---

From: Michael Paquier <[email-masked]>
Date: Tue, 7 May 2024 15:01:46 +0900

On Tue, May 07, 2024 at 12:44:51AM -0500, Tristan Partin wrote:
> Thanks for the feedback Michael. Should I just throw the patch in the next
> commitfest so it doesn't get left behind?

Better to do so, yes.  I have noted this thread in my TODO list, but
we're a couple of weeks away from the next CF and things tend to get
easily forgotten.
--
Michael

---

From: "Tristan Partin" <[email-masked]>
Date: Tue, 07 May 2024 12:47:18 -0500

> we're a couple of weeks away from the next CF and things tend to get

Added here: https://commitfest.postgresql.org/48/4978/

-- 
Tristan Partin
Neon (https://neon.tech)