Subject: xmltable SQL conformance

From: Peter Eisentraut <[email-masked]>
Date: Thu, 3 Aug 2017 16:14:45 -0400

I'm looking to update the SQL conformance list for the release.  I'm
wondering whether the new xmltable feature fully completes the following
items:

X300    XMLTable
X301    XMLTable: derived column list option
X302    XMLTable: ordinality column option
X303    XMLTable: column default option
X304    XMLTable: passing a context item

It looks so to me, but maybe you know more.

-- 
Peter Eisentraut              http://www.2ndQuadrant.com/
PostgreSQL Development, 24x7 Support, Remote DBA, Training & Services

-- 
Sent via pgsql-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-hackers

---

From: Pavel Stehule <[email-masked]>
Date: Thu, 3 Aug 2017 22:54:29 +0200

> It looks so to me, but maybe you know more.

I am not sure what X304 means? Other are not supported 100% .. are related
to unsupported XQuery lang.

Regards

Pavel

---

From: Pavel Stehule <[email-masked]>
Date: Thu, 3 Aug 2017 23:07:24 +0200

2017-08-03 22:54 GMT+02:00 Pavel Stehule <[email-masked]>:

>
>
> 2017-08-03 22:14 GMT+02:00 Peter Eisentraut <peter.eisentraut@2ndquadrant.
> com>:
>

Others than x300, 301, 302, 303 are unsupported. I don't understand to X304
well - related syntax is ignored in Postgres if I understand.

Pavel

---

From: Peter Eisentraut <[email-masked]>
Date: Mon, 7 Aug 2017 14:36:33 -0400

On 8/3/17 17:07, Pavel Stehule wrote:
>     I am not sure what X304 means? Other are not supported 100% .. are
>     related to unsupported XQuery lang.
> 
> 
> Others than x300, 301, 302, 303 are unsupported.

I think you mean supported here?  Because they quite clearly are.

> I don't understand to
> X304 well - related syntax is ignored in Postgres if I understand.

This means that you pass in the document to work on, which is supported.

Thanks for your input.  I have updated the features list accordingly.

---

From: Pavel Stehule <[email-masked]>
Date: Mon, 7 Aug 2017 20:47:07 +0200

> I think you mean supported here?  Because they quite clearly are.

I am sorry - it my bad English :( - Czechism