Subject: Re: configure failures on chipmunk

From: Heikki Linnakangas <[email-masked]>
Date: Wed, 21 Aug 2024 09:29:39 +0300

On 21/08/2024 01:42, Thomas Munro wrote:
> On Wed, Aug 21, 2024 at 9:48 AM Alvaro Herrera <[email-masked]> wrote:
>> Hi.  I noticed chipmunk is failing in configure:
>>
>> checking whether the C compiler works... no
>> configure: error: in `/home/pgbfarm/buildroot/HEAD/pgsql.build':
>> configure: error: C compiler cannot create executables
> 
> One of the runs shows:
> 
> ./configure: line 4202: 28268 Bus error               $CC -c $CFLAGS
> $CPPFLAGS conftest.$ac_ext 1>&5

Yeah, I've been slowly upgrading it to a new debian/raspbian version, 
and "ccache" started segfaulting, not sure why. I compiled ccache from 
sources, and now it seems to work when I run it on its own. Not sure why 
the buildfarm run still failed.

-- 
Heikki Linnakangas
Neon (https://neon.tech)

---

From: Alexander Lakhin <[email-masked]>
Date: Mon, 26 Aug 2024 07:00:00 +0300

Hello Heikki,

21.08.2024 09:29, Heikki Linnakangas wrote:
> Yeah, I've been slowly upgrading it to a new debian/raspbian version, and "ccache" started segfaulting, not sure why. 
> I compiled ccache from sources, and now it seems to work when I run it on its own. Not sure why the buildfarm run 
> still failed.
>

Could you also take a look at the kerberos setup on chipmunk? Now that
chipmunk goes beyond configure (on HEAD and REL_17_STABLE), it fails on the
kerberosCheck stage, with the following error:
Can't exec "/usr/sbin/kdb5_util": No such file or directory at 
/home/pgbfarm/buildroot/HEAD/pgsql.build/src/test/kerberos/../../../src/test/perl/PostgreSQL/Test/Utils.pm line 349.

Best regards,
Alexander

---

From: Alexander Lakhin <[email-masked]>
Date: Fri, 30 Aug 2024 07:00:00 +0300

Hello Heikki,

26.08.2024 07:00, Alexander Lakhin wrote:
> kerberosCheck stage, ...

I see that chipmunk turned green.

Thank you for taking care of that!

Best regards,
Alexander