Subject: Re: pgsql: Server-side gzip compression.

From: David Rowley <[email-masked]>
Date: Tue, 25 Jan 2022 22:19:58 +1300

On Tue, 25 Jan 2022 at 09:14, Robert Haas <[email-masked]> wrote:
> src/backend/replication/basebackup_gzip.c | 309 ++++++++++++++++++++++++++++++

This could do with the attached.  MSVC compilers need a bit more
reassurance that ereport/elog ERRORs don't return.

David

---

From: Robert Haas <[email-masked]>
Date: Tue, 25 Jan 2022 13:12:30 -0500

> reassurance that ereport/elog ERRORs don't return.

Err, well, if we need it, we need it. It surprises me, though:
wouldn't this same consideration apply to a very large number of other
places in the code base?

-- 
Robert Haas
EDB: http://www.enterprisedb.com

---

From: David Rowley <[email-masked]>
Date: Wed, 26 Jan 2022 09:56:10 +1300

> wouldn't this same consideration apply to a very large number of other

All of the other places are handled. See locations with "keep compiler quiet".

This one is the only one that generates a warning:

basebackup_gzip.c(90): warning C4715: 'bbsink_gzip_new': not all
control paths return a value

David

---

From: Robert Haas <[email-masked]>
Date: Thu, 27 Jan 2022 14:43:57 -0500

> control paths return a value

OK. I'm still surprised, but it is what it is. I've committed this now.

FWIW, I would have been fine with you just committing this change. I
can't see the warning locally, so I'm not in a position to
second-guess your statement that it's needed.

Thanks,

---

From: David Rowley <[email-masked]>
Date: Mon, 31 Jan 2022 17:07:47 +1300

> OK. I'm still surprised, but it is what it is. I've committed this now.

Thanks

> FWIW, I would have been fine with you just committing this change.

That's good to know, thanks for mentioning it.  FWIW, I just held back
as I wasn't 100% sure on the etiquette.

David