Subject: meson: pkgconfig difference

From: Peter Eisentraut <[email-masked]>
Date: Wed, 1 Feb 2023 08:40:52 +0100

I think there is a tiny typo in src/interfaces/ecpg/ecpglib/meson.build:

diff --git a/src/interfaces/ecpg/ecpglib/meson.build 
b/src/interfaces/ecpg/ecpglib/meson.build
index dba9e3c3d9..da8d304f54 100644
--- a/src/interfaces/ecpg/ecpglib/meson.build
+++ b/src/interfaces/ecpg/ecpglib/meson.build
@@ -57,7 +57,7 @@ pkgconfig.generate(
    description: 'PostgreSQL libecpg library',
    url: pg_url,
    libraries: ecpglib_so,
-  libraries_private: [frontend_shlib_code, thread_dep],
+  libraries_private: [frontend_stlib_code, thread_dep],
    requires_private: ['libpgtypes', 'libpq'],
  )

This makes it match the other libraries.

Without this change, we get

Libs.private: ... -lpgport_shlib -lpgcommon_shlib

which seems wrong.

---

From: Andres Freund <[email-masked]>
Date: Tue, 31 Jan 2023 23:55:46 -0800

Hi, 

On January 31, 2023 11:40:52 PM PST, Peter Eisentraut <[email-masked]> wrote:
>diff --git a/src/interfaces/ecpg/ecpglib/meson.build b/src/interfaces/ecpg/ecpglib/meson.build

Ugh, yes, that's wrong. Do you want me to apply the fix?

Regards,

Andres

-- 
Sent from my Android device with K-9 Mail. Please excuse my brevity.

---

From: Peter Eisentraut <[email-masked]>
Date: Wed, 1 Feb 2023 18:15:22 +0100

> Ugh, yes, that's wrong. Do you want me to apply the fix?

I've done it now.