Subject: Re: Ability to reference other extensions by schema in extension scripts

From: "Gregory Stark (as CFM)" <[email-masked]>
Date: Mon, 6 Mar 2023 13:49:51 -0500

It looks like this patch needs a quick rebase, there's a conflict in
the meson.build.

I'll leave the state since presumably this would be easy to resolve
but it would be more likely to get attention if it's actually building
cleanly.

http://cfbot.cputube.org/patch_42_4023.log

On Tue, 28 Feb 2023 at 18:44, Sandro Santilli <[email-masked]> wrote:
>
> The following review has been posted through the commitfest application:
> make installcheck-world:  tested, failed
> Implements feature:       tested, passed
> Spec compliant:           tested, passed
> Documentation:            tested, passed
>
> I've applied the patch attached to message https://www.postgresql.org/message-id/000401d94bc8%2448dff700%24da9fe500%24%40pcorp.us (md5sum a7d45a32c054919d94cd4a26d7d07c20) onto current tip of the master branch being 128dd9f9eca0b633b51ffcd5b0f798fbc48ec4c0
>
> The review written in https://www.postgresql.org/message-id/20230228224608.ak7br5shev4wic5a%40c19 all still applies.
>
> The `make installcheck-world`  test fails for me but the failures seem unrelated to the patch (many occurrences of "+ERROR:  function pg_input_error_info(unknown, unknown) does not exist" in the regression.diff).
>
> Documentation exists for the new feature
>
> The new status of this patch is: Ready for Committer

-- 
Gregory Stark
As Commitfest Manager

---

From: "Regina Obe" <[email-masked]>
Date: Mon, 6 Mar 2023 16:40:29 -0500

> It looks like this patch needs a quick rebase, there's a conflict in the
> meson.build.
> 
> I'll leave the state since presumably this would be easy to resolve but it would
> be more likely to get attention if it's actually building cleanly.
> 
> > I've applied the patch attached to message
> > https://www.postgresql.org/message-
> id/000401d94bc8%2448dff700%24da9fe5
> > 00%24%40pcorp.us (md5sum a7d45a32c054919d94cd4a26d7d07c20) onto
> > current tip of the master branch being
> > 128dd9f9eca0b633b51ffcd5b0f798fbc48ec4c0
> >
> > The review written in https://www.postgresql.org/message-
> id/20230228224608.ak7br5shev4wic5a%40c19 all still applies.
> >
> > The `make installcheck-world`  test fails for me but the failures seem
> unrelated to the patch (many occurrences of "+ERROR:  function
> pg_input_error_info(unknown, unknown) does not exist" in the
> regression.diff).
> >

Just sent a note about the wildcard one.  Was this conflicting with the wildcard one or some other.
I can rebase if it was conflicting with another one, if it was the wildcard one, then maybe we should commit this one and we'll rebase the wildcard one.

We would like to submit the wildcard one too, but I think Tom had some reservations on that one.

Thanks,
Regina