Subject: Re: Missing docs for new enable_group_by_reordering GUC

From: Andrei Lepikhov <[email-masked]>
Date: Tue, 18 Jun 2024 13:13:54 +0700

On 6/18/24 09:32, Bruce Momjian wrote:
> This commit added enable_group_by_reordering:
> 
> 	commit 0452b461bc4
> 	Author: Alexander Korotkov <[email-masked]>
> 	Date:   Sun Jan 21 22:21:36 2024 +0200
> It mentions it was added as a GUC to postgresql.conf, but I see no SGML
> docs for this new GUC value.  Would someone please add docs for this?
> Thanks.
It is my mistake, sorry for that. See the patch in attachment.

-- 
regards, Andrei Lepikhov
From b2d5aca0547bf912032ad60a30a55ef86a28708e Mon Sep 17 00:00:00 2001
From: "Andrei V. Lepikhov" <[email-masked]>
Date: Tue, 18 Jun 2024 13:11:52 +0700
Subject: [PATCH] Add doc entry for the new paramenter
 enable_group_by_reordering

---
 doc/src/sgml/config.sgml | 14 ++++++++++++++
 1 file changed, 14 insertions(+)

diff --git a/doc/src/sgml/config.sgml b/doc/src/sgml/config.sgml
index 698169afdb..61093a033d 100644
--- a/doc/src/sgml/config.sgml
+++ b/doc/src/sgml/config.sgml
@@ -5327,6 +5327,20 @@ ANY <replaceable class="parameter">num_sync</replaceable> ( <replaceable class="
       </listitem>
      </varlistentry>
 
+     <varlistentry id="guc-enable-groupby-reordering" xreflabel="enable_group_by_reordering">
+      <term><varname>enable_group_by_reordering</varname> (<type>boolean</type>)
+      <indexterm>
+       <primary><varname>enable_group_by_reordering</varname> configuration parameter</primary>
+      </indexterm>
+      </term>
+      <listitem>
+       <para>
+        Enables or disables reordering of keys in a <literal>GROUP BY</literal>
+        clause. The default is <literal>on</literal>.
+       </para>
+      </listitem>
+     </varlistentry>
+
      <varlistentry id="guc-enable-gathermerge" xreflabel="enable_gathermerge">
       <term><varname>enable_gathermerge</varname> (<type>boolean</type>)
       <indexterm>
-- 
2.39.2

---

From: Alexander Korotkov <[email-masked]>
Date: Tue, 18 Jun 2024 15:13:11 +0300

> It is my mistake, sorry for that. See the patch in attachment.

Bruce, thank for noticing.  Andrei, thank you for providing a fix.
Please, check the revised patch.

------
Regards,
Alexander Korotkov
Supabase