Subject: Change of behaviour for creating same type name in multiple schemas

From: Dave Cramer <[email-masked]>
Date: Thu, 5 Oct 2023 08:08:36 -0400

Greetings,

Before 16 if I created an array type in schema1 it would be named
schema1._array_type
if I created the same type in schema 2 it would have been named

schema2.__array_type

Can someone point me to where the code was changed ?

Thanks,
Dave Cramer

---

From: Matthias van de Meent <[email-masked]>
Date: Thu, 5 Oct 2023 14:31:00 +0200

On Thu, 5 Oct 2023 at 14:13, Dave Cramer <[email-masked]> wrote:
>
> Greetings,
>
> Before 16 if I created an array type in schema1 it would be named schema1._array_type

This was with commit 70988b7b [0] in July 2022, based on this thread
[1] (moved from -bugs).

Kind regards,

Matthias van de Meent
Neon (https://neon.tech)

[0] https://github.com/postgres/postgres/commits/70988b7b0a0bd03c59a2314d0b5bcf2135692349
[1] https://www.postgresql.org/message-id/flat/b84cd82c-cc67-198a-8b1c-60f44e1259ad%40postgrespro.ru