Subject: Re: file_fdw: Support multi-line HEADER option.

From: Álvaro Herrera <[email-masked]>
Date: Tue, 20 Jan 2026 16:07:43 +0100

On 2026-Jan-20, Fujii Masao wrote:

> I'm thinking to commit the attached patches.

In 0001 I would recommend to move the string "match" to outside the
message.  Otherwise a translator might be tempted to translate it, and
then it would make no sense.  (I have never seen this happen in
Postgres, but I have seen this kind of translation mistake in other
software, and it is infuriating.)

-- 
Álvaro Herrera               48°01'N 7°57'E  —  https://www.EnterpriseDB.com/
"Los minutos y los segundos son mercadería de la ciudad, donde un infeliz se
afana por no perder ni siquiera un segundo y no advierto que obrando de ese
modo pierde una vida."              ("La vuelta de Don Camilo", G. Guareschi)

---

From: Fujii Masao <[email-masked]>
Date: Wed, 21 Jan 2026 16:38:58 +0900

> software, and it is infuriating.)

Thanks for the review!

Agreed. I've updated the patches as suggested.
The revised versions are attached.

Regards,

-- 
Fujii Masao

---

From: Steven Niu <[email-masked]>
Date: Wed, 21 Jan 2026 08:18:41 +0000

From: Fujii Masao <[email-masked]>
Sent: Wednesday, January 21, 2026 15:38
To: Álvaro Herrera <[email-masked]>
Cc: Shinya Kato <[email-masked]>; Chao Li <[email-masked]>; PostgreSQL-development <[email-masked]>
Subject: Re: file_fdw: Support multi-line HEADER option.

Thanks for the review!

Regards,

-- 
Fujii Masao

________________________________________

Hi Fujii-san, 

I've noticed an inconsistent naming convention in the patch: 
we use a capitalized Boolean for the boolean type, but a lowercase integer when referring to the value type. 

+ errmsg("%s requires a Boolean value, an integer "
+		"value greater than or equal to zero

Is there any reason why we follow this mixed style? 

Another nitpick in v6-0001 patch: 
tow whitespaces are between "special" and "value"
+		 second %s is the special  value "match" for that option */

Thanks,
Steven

---

From: Fujii Masao <[email-masked]>
Date: Thu, 22 Jan 2026 10:18:08 +0900

> Is there any reason why we follow this mixed style?

I don't have a strong opinion on this. "Boolean value" has been used in command
error messages from before, and I couldn't find any messages that use the term
"Integer". So I committed the patch with the original wording. If this turns out
to be an issue, we can revisit it later.

> +                second %s is the special  value "match" for that option */

Thanks for catching that! I've fixed it.

I've pushed the patches. Thanks!

Regards,

-- 
Fujii Masao