Subject: Minor document typo

From: Tatsuo Ishii <[email-masked]>
Date: Tue, 23 Apr 2024 20:17:39 +0900 (JST)

Hi,

doc/src/sgml/monitoring.sgml seems to have a minor typo:

In pg_stat_database_conflicts section (around line 3621) we have:

      <para>
       Number of uses of logical slots in this database that have been
       canceled due to old snapshots or too low a <xref linkend="guc-wal-level"/>
       on the primary
      </para></entry>

I think "too low a" should be "too low" ('a' is not
necessary). Attached is the patch.

Best reagards,
--
Tatsuo Ishii
SRA OSS LLC
English: http://www.sraoss.co.jp/index_en/
Japanese:http://www.sraoss.co.jp
diff --git a/doc/src/sgml/monitoring.sgml b/doc/src/sgml/monitoring.sgml
index 053da8d6e4..56e79b1304 100644
--- a/doc/src/sgml/monitoring.sgml
+++ b/doc/src/sgml/monitoring.sgml
@@ -3618,7 +3618,7 @@ description | Waiting for a newly initialized WAL file to reach durable storage
       </para>
       <para>
        Number of uses of logical slots in this database that have been
-       canceled due to old snapshots or too low a <xref linkend="guc-wal-level"/>
+       canceled due to old snapshots or too low <xref linkend="guc-wal-level"/>
        on the primary
       </para></entry>
      </row>

---

From: David Rowley <[email-masked]>
Date: Tue, 23 Apr 2024 23:36:52 +1200

> necessary). Attached is the patch.

The existing text looks fine to me.  The other form would use "of a"
and become "too low of a wal_level on the primary".

"too low wal_level on the primary" sounds wrong to my native
English-speaking ear.

There's some discussion in [1] that might be of interest to you.

David

[1] https://www.reddit.com/r/grammar/comments/qr9z6e/i_need_help_with_sothat_adj_of_a_sing_noun/?ref=share&ref_source=link

---

From: Tatsuo Ishii <[email-masked]>
Date: Tue, 23 Apr 2024 21:11:38 +0900 (JST)

> [1] https://www.reddit.com/r/grammar/comments/qr9z6e/i_need_help_with_sothat_adj_of_a_sing_noun/?ref=share&ref_source=link

Thank you for the explanation. English is difficult :-)

Just out of a curiosity, is it possible to say "low a wal_level on the
primary"? (just "too" is removed)
--
Tatsuo Ishii
SRA OSS LLC
English: http://www.sraoss.co.jp/index_en/
Japanese:http://www.sraoss.co.jp

---

From: David Rowley <[email-masked]>
Date: Wed, 24 Apr 2024 01:45:25 +1200

> primary"? (just "too" is removed)

Prefixing the adjective with "too" means it's beyond the acceptable
range.  "This coffee is too hot".

https://dictionary.cambridge.org/grammar/british-grammar/too

David