Subject: Re: Detailed release notes

From: Daniel Gustafsson <[email-masked]>
Date: Fri, 26 Jul 2024 14:45:20 +0200

> On 26 Jul 2024, at 14:30, Marcos Pegoraro <[email-masked]> wrote:
> 
> I'm now using version 14 and planning to update to 17 as soon as it comes available. Then looking carefully to release notes to see exactly what I'll get when updated I see lots of unexplained features. Just because release notes does not explain exactly what that change does. And I don't have a way to get what code or messages generated that feature.

There is a way, but it's not exactly visible from reading the release notes.

>     • Allow query nodes to be run in parallel in more cases (Tom Lane)
> Cool this feature, but when and what kind of query will use this ?

Reading the source of the release notes will show a comment which links to the
commit.  The source can be seen here:

    https://github.com/postgres/postgres/blob/REL_17_STABLE/doc/src/sgml/release-17.sgml

..and the comment for this item is:

<!--
Author: Tom Lane <[email-masked]>
2023-07-14 [e08d74ca1] Allow plan nodes with initPlans to be considered paralle
-->

      <listitem>
       <para>
       Allow query nodes to be run in parallel in more cases (Tom Lane)
       </para>
      </listitem>

This comment tells us the relevant commit is e08d74ca1, which can be found here:

    https://github.com/postgres/postgres/commit/e08d74ca1

This in turn leads to the mailinglist discussion for this specific feature:

    https://www.postgresql.org/message-id/[email-masked]

--
Daniel Gustafsson

---

From: Marcos Pegoraro <[email-masked]>
Date: Fri, 26 Jul 2024 10:00:33 -0300

> There is a way, but it's not exactly visible from reading the release

Cool, didn't know that.
But why is that just a hidden comment and not a visible link for us ?

regards
Marcos